aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2018-09-20 14:24:54 -0400
committerTed Hess <thess@kitschensync.net>2018-09-20 14:25:11 -0400
commitdd8b63764664dd3e7ab31394bf82f81f6567477d (patch)
tree62e3505e7dcb9c2e5fb27f073f9ab7ebeb6ef4ed
parent511f39f7d0f364b5c2ff8174e54feab692e8aea7 (diff)
boost: Fix mips32r1 cpu builds (exclude Boost.fiber)
Signed-off-by: Ted Hess <thess@kitschensync.net>
-rw-r--r--libs/boost/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index cfbc8c843..ae1e3d2a4 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -234,6 +234,11 @@ define Package/boost/config
select boost-coroutine2
select boost-graph-parallel
+ # Invisible config dependency
+ config boost-fiber-exclude
+ bool
+ default y if (CPU_TYPE=mips32 || CPU_TYPE=mips64)
+
config boost-test-pkg
bool "Boost test package."
default m if ALL
@@ -256,7 +261,7 @@ define Package/boost/config
default m if ALL
$(if $(findstring locale,$(lib)),depends on BUILD_NLS,)\
$(if $(findstring python,$(lib)),depends on PACKAGE_$(lib),)\
- $(if $(findstring fiber,$(lib)),depends on CPU_TYPE!=mips32 && CPU_TYPE!=mips64,)
+ $(if $(findstring fiber,$(lib)),depends on (CPU_TYPE!=mips32 && CPU_TYPE!=mips64),)
)
endmenu
@@ -305,7 +310,7 @@ $(eval $(call DefineBoostLibrary,contract,system,))
$(eval $(call DefineBoostLibrary,coroutine,system chrono context thread,))
$(eval $(call DefineBoostLibrary,date_time,,))
#$(eval $(call DefineBoostLibrary,exception,,))
-$(eval $(call DefineBoostLibrary,fiber,coroutine filesystem,,))
+$(eval $(call DefineBoostLibrary,fiber,coroutine filesystem,,!boost-fiber-exclude))
$(eval $(call DefineBoostLibrary,filesystem,system,))
$(eval $(call DefineBoostLibrary,graph,regex,))
$(eval $(call DefineBoostLibrary,iostreams,,+zlib +liblzma +libbz2))