aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2015-08-20 10:55:42 -0400
committerTed Hess <thess@kitschensync.net>2015-08-20 10:55:42 -0400
commitdd79bf0f49d914494299396930a3ba7c326cc8b1 (patch)
tree8a9c24b43710730a2e91bbf97555c81218d7fa87
parenta94f520bcd410beb3c874bdf745a082ff4f24c4e (diff)
parentac8ed17be989d9abc418494a908cc4dba99877ff (diff)
Merge pull request #1682 from ClaymorePT/master
boost: Boost Makefile Update to Version 1.59
-rw-r--r--libs/boost/Makefile7
-rw-r--r--libs/boost/patches/001-mips-options-fix.patch11
2 files changed, 4 insertions, 14 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index c2d273e7e..2a6e9f3e5 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -16,14 +16,14 @@ include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=boost
-PKG_VERSION:=1_58_0
-PKG_RELEASE:=6
+PKG_VERSION:=1_59_0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/boost
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_VERSION)
-PKG_MD5SUM:=5a5d5614d9a07672e1ab2a250b5defc5
+PKG_MD5SUM:=51528a0e3b33d9e10aaa311d9eb451e3
PKG_LICENSE:=Boost Software License <http://www.boost.org/users/license.html>
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
@@ -109,6 +109,7 @@ define Package/boost-test
$(call Package/boost/Default)
TITLE+= (test)
HIDDEN:=1
+ DEPENDS+=+boost-system +boost-timer
endef
define Build/Configure
diff --git a/libs/boost/patches/001-mips-options-fix.patch b/libs/boost/patches/001-mips-options-fix.patch
deleted file mode 100644
index d9b30e6e9..000000000
--- a/libs/boost/patches/001-mips-options-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- boost_1_58_0/tools/build/src/tools/gcc.jam 2015-04-23 12:01:37.723438995 +0200
-+++ boost_1_58_0/tools/build/src/tools/gcc.jam 2015-04-23 12:00:21.427441384 +0200
-@@ -451,7 +451,7 @@
- else
- {
- local arch = [ feature.get-values architecture : $(properties) ] ;
-- if $(arch) != arm
-+ if $(arch) = power || $(arch) = sparc || $(arch) = x86
- {
- if $(model) = 32
- {