aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-12-07 09:13:28 -0200
committerEneas U de Queiroz <cote2004-github@yahoo.com>2018-12-07 09:35:13 -0200
commitda9dda6412c79f9bf1c6fd0a1ed193f6c6114f4e (patch)
treebfd4db214ac597b5806780f5fcc0de68eb5e60eb
parentbfc2435f7d42d0978755102864a8ecc8bb6518ea (diff)
libyaml-cpp: copy file matching libs soname
The soname is not set to the full version, but only major.minor. This uses libyaml-cpp.so.?.? to try to get it right. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
-rw-r--r--libs/libyaml-cpp/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/libs/libyaml-cpp/Makefile b/libs/libyaml-cpp/Makefile
index 74c93b39d..b71be2d62 100644
--- a/libs/libyaml-cpp/Makefile
+++ b/libs/libyaml-cpp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libyaml-cpp
PKG_VERSION:=0.6.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=yaml-cpp-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/jbeder/yaml-cpp/tar.gz/yaml-cpp-$(PKG_VERSION)?
@@ -46,9 +46,8 @@ endef
define Package/libyaml-cpp/install
$(INSTALL_DIR) $(1)/usr/lib
- #$(INSTALL_DATA) $(PKG_BUILD_DIR)/libyaml-cpp.so.0.5.3 $(1)/usr/lib/
- #$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libyaml-cpp.so.0.5.3 $(1)/usr/lib/
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libyaml-cpp.so.$(PKG_VERSION) $(1)/usr/lib/
+ #$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libyaml-cpp.so.0.6 $(1)/usr/lib/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libyaml-cpp.so.?.? $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libyaml-cpp))