aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWaldemar Konik <informatyk74@interia.pl>2022-12-20 16:44:15 +0100
committerRosen Penev <rosenp@gmail.com>2022-12-22 16:32:31 -0800
commitda564ae8cca1d481a991aa28d062a17ca81a4b97 (patch)
tree5c4a75c3e0643344b2f0c44e640bf473e65b2a47
parenta54c2caa9c1d33c4accf724f00cb7a601899001e (diff)
python-curl: update to version 7.45.2
PycURL changeLog: ----------------------------------------------------------------- PycURL 7.45.2 - 2022-12-16 ----------------------------------------------------------------- This release fixes several minor issues and adds support for several libcurl options. ----------------------------------------------------------------- PycURL 7.45.1 - 2022-03-13 ----------------------------------------------------------------- This release fixes build when libcurl < 7.64.1 is used. ----------------------------------------------------------------- PycURL 7.45.0 - 2022-03-09 ----------------------------------------------------------------- This release adds support for SecureTransport SSL backend (MacOS), adds ability to unset a number of multi options, adds ability to duplicate easy handles and permits pycurl classes to be subclassed. ----------------------------------------------------------------- PycURL 7.44.1 - 2021-08-15 ----------------------------------------------------------------- This release repairs incorrect Python thread initialization logic which caused operations to hang. ----------------------------------------------------------------- Signed-off-by: Waldemar Konik <informatyk74@interia.pl> Compile tested: x86_64
-rw-r--r--lang/python/python-curl/Makefile6
-rw-r--r--lang/python/python-curl/patches/100_macos_compat.patch2
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/python/python-curl/Makefile b/lang/python/python-curl/Makefile
index 630ccd941..4f46dc5fc 100644
--- a/lang/python/python-curl/Makefile
+++ b/lang/python/python-curl/Makefile
@@ -5,11 +5,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pycurl
-PKG_VERSION:=7.44.0
-PKG_RELEASE:=2
+PKG_VERSION:=7.45.2
+PKG_RELEASE:=1
PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=2ce9905626d8ceafcbadee666e2f45397e29c7618ddcdc63fc22d85e5046c6d6
+PKG_HASH:=5730590be0271364a5bddd9e245c9cc0fb710c4cbacbdd95264a3122d23224ca
PKG_MAINTAINER:=Waldemar Konik <informatyk74@interia.pl>
PKG_LICENSE:=LGPL-2.1
diff --git a/lang/python/python-curl/patches/100_macos_compat.patch b/lang/python/python-curl/patches/100_macos_compat.patch
index fc233da2a..ba5e0b8da 100644
--- a/lang/python/python-curl/patches/100_macos_compat.patch
+++ b/lang/python/python-curl/patches/100_macos_compat.patch
@@ -3,7 +3,7 @@ This patch should be deleted after resolving https://github.com/pycurl/pycurl/is
---
--- a/setup.py
+++ b/setup.py
-@@ -347,9 +347,6 @@ manually. For other SSL backends please
+@@ -341,9 +341,6 @@ ignore this message.''')
if not self.libraries:
self.libraries.append("curl")