aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-08-12 01:51:19 +0800
committerJeffery To <jeffery.to@gmail.com>2023-08-12 01:51:19 +0800
commitda25e997259e0999a0531fca2a4269c7c7f4fdd4 (patch)
tree65df3e3c35f38972c1b32bb05cbb14ee6c6ce7bf
parentfce22d0d842f6d859aced9324d50098eb44df1e2 (diff)
python-netdisco: Update to 3.0.0, update list of dependencies
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python-netdisco/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/lang/python/python-netdisco/Makefile b/lang/python/python-netdisco/Makefile
index 377afead9..1c497190e 100644
--- a/lang/python/python-netdisco/Makefile
+++ b/lang/python/python-netdisco/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-netdisco
-PKG_VERSION:=2.6.0
-PKG_RELEASE:=2
+PKG_VERSION:=3.0.0
+PKG_RELEASE:=1
PYPI_NAME:=netdisco
-PKG_HASH:=2b3aca14a1807712a053f11fd80dc251dd821ee4899aefece515287981817762
+PKG_HASH:=4dbb590482f377ccc461e01742707ccbe8f1d2d1b28578af91dc9b7febcdcbd2
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=Apache-2.0
@@ -30,13 +30,17 @@ define Package/python3-netdisco
URL:=https://github.com/home-assistant/netdisco
DEPENDS:= \
+python3-light \
+ +python3-logging \
+ +python3-urllib \
+ +python3-xml \
+python3-requests \
+python3-zeroconf
endef
define Package/python3-netdisco/description
- NetDisco is a Python 3 library to discover local devices and services.
- It allows to scan on demand or offer a service that will scan the network in the background in a set interval.
+NetDisco is a Python 3 library to discover local devices and services.
+It allows to scan on demand or offer a service that will scan the
+network in the background in a set interval.
endef
$(eval $(call Py3Package,python3-netdisco))