aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-09-30 01:58:18 -0700
committerGitHub <noreply@github.com>2020-09-30 01:58:18 -0700
commitd98d29735d1b2b246494f8009589c43409180f3c (patch)
tree542d873188244620b87de5ca46898ec574bd7cae
parent527b3e2119a9e66e10cb6f05c57df1c345785f64 (diff)
parent87a4eeb8de28caa4a054efc1b8a8c3e5ac11b47d (diff)
Merge pull request #13518 from neheb/cryptse
cryptsetup: fix compilation with full NLS
-rw-r--r--utils/cryptsetup/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/utils/cryptsetup/Makefile b/utils/cryptsetup/Makefile
index a87f07d45..9c23be724 100644
--- a/utils/cryptsetup/Makefile
+++ b/utils/cryptsetup/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cryptsetup
PKG_VERSION:=2.3.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/cryptsetup/v2.3
@@ -30,7 +30,7 @@ define Package/cryptsetup
CATEGORY:=Utilities
SUBMENU:=Encryption
TITLE:=Cryptsetup
- DEPENDS:=$(ICONV_DEPENDS) +libblkid +libuuid +libpopt +lvm2 +libdevmapper +libjson-c +@KERNEL_DIRECT_IO +kmod-crypto-user
+ DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +libblkid +libuuid +libpopt +lvm2 +libdevmapper +libjson-c +@KERNEL_DIRECT_IO +kmod-crypto-user
URL:=https://gitlab.com/cryptsetup/cryptsetup/
endef
@@ -49,8 +49,6 @@ CONFIGURE_ARGS += \
--with-luks2-lock-path=/var/run/cryptsetup \
--with-crypto_backend=kernel
-TARGET_LDFLAGS += -liconv
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/libcryptsetup.h $(1)/usr/include