aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Wagner <tripolar@gmx.at>2019-01-15 20:33:38 +0100
committerPeter Wagner <tripolar@gmx.at>2019-01-15 20:34:03 +0100
commitd82cc22019f8e31cf1417497c2ff038f0c642650 (patch)
tree81bd528eb7571183b9205ae4efa9d7a244e5dd7f
parent6633ac3afd07961fc1da95a6e9475785f159a588 (diff)
openssh: backport patch for CVE-2018-20685
Signed-off-by: Peter Wagner <tripolar@gmx.at>
-rw-r--r--net/openssh/Makefile2
-rw-r--r--net/openssh/patches/0000-CVE-2018-20685.patch33
2 files changed, 34 insertions, 1 deletions
diff --git a/net/openssh/Makefile b/net/openssh/Makefile
index 09063abaa..e37920bd2 100644
--- a/net/openssh/Makefile
+++ b/net/openssh/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssh
PKG_VERSION:=7.9p1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
diff --git a/net/openssh/patches/0000-CVE-2018-20685.patch b/net/openssh/patches/0000-CVE-2018-20685.patch
new file mode 100644
index 000000000..f2f1ecfc5
--- /dev/null
+++ b/net/openssh/patches/0000-CVE-2018-20685.patch
@@ -0,0 +1,33 @@
+From 6010c0303a422a9c5fa8860c061bf7105eb7f8b2 Mon Sep 17 00:00:00 2001
+From: "djm@openbsd.org" <djm@openbsd.org>
+Date: Fri, 16 Nov 2018 03:03:10 +0000
+Subject: [PATCH] upstream: disallow empty incoming filename or ones that refer
+ to the
+
+current directory; based on report/patch from Harry Sintonen
+
+OpenBSD-Commit-ID: f27651b30eaee2df49540ab68d030865c04f6de9
+---
+ scp.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/scp.c b/scp.c
+index 60682c687..4f3fdcd3d 100644
+--- a/scp.c
++++ b/scp.c
+@@ -1,4 +1,4 @@
+-/* $OpenBSD: scp.c,v 1.197 2018/06/01 04:31:48 dtucker Exp $ */
++/* $OpenBSD: scp.c,v 1.198 2018/11/16 03:03:10 djm Exp $ */
+ /*
+ * scp - secure remote copy. This is basically patched BSD rcp which
+ * uses ssh to do the data transfer (instead of using rcmd).
+@@ -1106,7 +1106,8 @@ sink(int argc, char **argv)
+ SCREWUP("size out of range");
+ size = (off_t)ull;
+
+- if ((strchr(cp, '/') != NULL) || (strcmp(cp, "..") == 0)) {
++ if (*cp == '\0' || strchr(cp, '/') != NULL ||
++ strcmp(cp, ".") == 0 || strcmp(cp, "..") == 0) {
+ run_err("error: unexpected filename: %s", cp);
+ exit(1);
+ }