aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-04-15 11:55:37 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-04-18 17:40:06 +0200
commitd768d36d8f69fe9751ff9d4340c5d7ff565bb794 (patch)
tree748ddb2cad68942d6e42295221a498d37e7fba6b
parentee50351b7f784b007ab43237f680a6747e58ced4 (diff)
gnunet: update to revision 37051 plus some small fixes
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--net/gnunet/Makefile4
-rw-r--r--net/gnunet/files/gnunet.init15
2 files changed, 12 insertions, 7 deletions
diff --git a/net/gnunet/Makefile b/net/gnunet/Makefile
index fd2476576..f4833404b 100644
--- a/net/gnunet/Makefile
+++ b/net/gnunet/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gnunet
-PKG_SOURCE_VERSION:=36986
+PKG_SOURCE_VERSION:=37051
PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
@@ -216,7 +216,7 @@ LIBEXEC_fs:=helper-fs-publish service-fs
CONF_fs:=fs
DEPENDS_gns:=+gnunet-vpn
-USERID_gns:=gnunetdns=401:gnunetdns=401
+USERID_gns:=gnunet=400:gnunetdns=401
BIN_gns:=gns gns-import.sh namecache namestore resolver
LIB_gns:=gns gnsrecord namecache namestore
PLUGIN_gns:=block_dns block_gns gnsrecord_dns gnsrecord_gns
diff --git a/net/gnunet/files/gnunet.init b/net/gnunet/files/gnunet.init
index 379d0d69e..81ecaf2ee 100644
--- a/net/gnunet/files/gnunet.init
+++ b/net/gnunet/files/gnunet.init
@@ -8,15 +8,15 @@ USE_PROCD=1
PROG=/usr/lib/gnunet/libexec/gnunet-service-arm
GNUNET_HOME=/var/run/gnunet
-LOGFILE=$GNUNET_HOME/gnunet.log
+# LOGFILE=$GNUNET_HOME/gnunet.log
CONFIGFILE=$GNUNET_HOME/gnunet.conf
SUID_ROOT_HELPERS="exit nat-server nat-client transport-bluetooth transport-wlan vpn"
chmodown_execbin() {
execname=/usr/lib/gnunet/libexec/gnunet-$1
if [ -x $execname ]; then
- chmod $2 $execname
[ "$3" ] && chown $3 $execname
+ chmod $2 $execname
fi
}
@@ -26,7 +26,7 @@ fix_libexec_permissions() {
chmodown_execbin helper-$helper u+s
done
chmodown_execbin helper-dns 4750 root:gnunetdns
- chmodown_execbin service-dns 2750 root:gnunetdns
+ chmodown_execbin service-dns 2750 gnunet:gnunetdns
touch /usr/share/gnunet/.permfix
}
@@ -38,7 +38,7 @@ prepare_config() {
chmod 0750 $GNUNET_HOME
fi
touch $CONFIGFILE
- chown root:gnunet $CONFIGFILE
+ chown gnunet:gnunet $CONFIGFILE
chmod 0640 $CONFIGFILE
gnunet-config -c $CONFIGFILE -s PATHS -o GNUNET_HOME -V $GNUNET_HOME
@@ -66,6 +66,10 @@ prepare_config() {
done
gnunet-config -c $CONFIGFILE -s transport -o PLUGINS -V "$transport_plugins"
+ # do not touch sysctl, iptables and routing
+ gnunet-config -c $CONFIGFILE -s dns -o SKIP_ROUTING_SETUP -V YES
+ gnunet-config -c $CONFIGFILE -s exit -o EXIT_IFNAME -V ''
+
# apply config from UCI
_gnunet_section=""
config_cb()
@@ -95,7 +99,8 @@ start_service() {
procd_open_instance
procd_set_param user gnunet
- procd_set_param command $PROG -c $CONFIGFILE -l $LOGFILE
+ procd_set_param command $PROG -c $CONFIGFILE
+ [ "$LOGFILE" ] && procd_append_param command -l $LOGFILE
procd_set_param respawn
procd_close_instance
}