aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2020-05-21 18:46:36 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2020-05-21 19:10:19 +0800
commitd6c66721cb7d2cb0380f8bb07542a3d361ca178d (patch)
tree307c8fbc71cbfb0e6ae8cfec71345bd22a50b7cc
parentba6e5fc393f0f843c786e949a389c8a2835eb490 (diff)
exfat-nofuse: use $(KERNEL_MAKE) to account for reproducible build
This leverages on -iremap flag embedded there since the build system commit 4ed356fa719e ("kernel.mk: add KCFLAGS to make kmods reproducible") Reported-by: Paul Spooren <mail@aparcar.org> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
-rw-r--r--kernel/exfat-nofuse/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/kernel/exfat-nofuse/Makefile b/kernel/exfat-nofuse/Makefile
index 7ea049831..f9110b733 100644
--- a/kernel/exfat-nofuse/Makefile
+++ b/kernel/exfat-nofuse/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=exfat-nofuse
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=https://github.com/dorimanx/exfat-nofuse.git
PKG_SOURCE_PROTO:=git
@@ -36,15 +36,10 @@ define KernelPackage/fs-exfat0/description
Kernel module for ExFAT Filesytems
endef
-MAKE_OPTS:= \
- ARCH="$(LINUX_KARCH)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- M="$(PKG_BUILD_DIR)"
-
define Build/Compile
- $(MAKE) -C "$(LINUX_DIR)" \
- $(MAKE_OPTS) \
+ $(KERNEL_MAKE) \
CONFIG_EXFAT_FS=m \
+ M="$(PKG_BUILD_DIR)" \
modules
endef