aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-07-09 12:54:17 -0700
committerGitHub <noreply@github.com>2021-07-09 12:54:17 -0700
commitd64eaa879616e1af32df96c8e2299d4676d7d32c (patch)
tree40605f4eedcfe9143c646b738a1f9418468db04d
parent4124421cd52d46bf5209ab98bbf17d21626e55c2 (diff)
parentdb6a4f797ffeb4d624678943e9bc1b6992f61917 (diff)
Merge pull request #16072 from neheb/nutt
nut: fix compilation with GCC11
-rw-r--r--net/nut/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/nut/Makefile b/net/nut/Makefile
index c26c5832c..0cc4afc32 100644
--- a/net/nut/Makefile
+++ b/net/nut/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nut
PKG_VERSION:=2.7.4
-PKG_RELEASE:=22
+PKG_RELEASE:=23
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.networkupstools.org/source/2.7/
@@ -542,6 +542,8 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_PACKAGE_nut-web-cgi),--with-gd-includes="`pkg-config --cflags gdlib`") \
$(if $(CONFIG_PACKAGE_nut-web-cgi),--with-gd-libs="`pkg-config --libs gdlib`")
+TARGET_CXXFLAGS += -std=c++98
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so* $(1)/usr/lib/