aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Ardelean <alex@shruggie.ro>2023-07-15 23:59:08 +0300
committerAlexandru Ardelean <alex@shruggie.ro>2023-07-16 22:09:55 +0300
commitd6252bcb763b0c9dfedf792d4a34eceb5abdfb04 (patch)
tree49b52d934ed18cec505babaae080f8fa1d212f52
parenta5e58afe1966cf7dd6c3df4c8068cff0b2a18c96 (diff)
numpy: bump to version 1.25.1
Signed-off-by: Alexandru Ardelean <alex@shruggie.ro>
-rw-r--r--lang/python/numpy/Makefile6
-rw-r--r--lang/python/numpy/patches/001-unpin-build-dependencies.patch17
-rw-r--r--lang/python/numpy/patches/002-avoid-build-user-config-files.patch2
3 files changed, 14 insertions, 11 deletions
diff --git a/lang/python/numpy/Makefile b/lang/python/numpy/Makefile
index bb5b898d1..54bbc4255 100644
--- a/lang/python/numpy/Makefile
+++ b/lang/python/numpy/Makefile
@@ -6,11 +6,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=numpy
-PKG_VERSION:=1.24.3
+PKG_VERSION:=1.25.1
PKG_RELEASE:=1
PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=ab344f1bf21f140adab8e47fdbc7c35a477dc01408791f8ba00d018dd0bc5155
+PKG_HASH:=9a3a9f3a61480cc086117b426a8bd86869c213fc4072e606f01c4e4b66eb92bf
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
@@ -37,7 +37,7 @@ define Package/python3-numpy
CATEGORY:=Languages
TITLE:=The fundamental package for scientific computing with Python
URL:=https://www.numpy.org/
- DEPENDS:=@!SOFT_FLOAT +INSTALL_GFORTRAN:libgfortran +python3 \
+ DEPENDS:=@!SOFT_FLOAT +INSTALL_GFORTRAN:libgfortran +python3 +libstdcpp \
+NUMPY_OPENBLAS_SUPPORT:openblas
endef
diff --git a/lang/python/numpy/patches/001-unpin-build-dependencies.patch b/lang/python/numpy/patches/001-unpin-build-dependencies.patch
index 1606762b0..dbfaea505 100644
--- a/lang/python/numpy/patches/001-unpin-build-dependencies.patch
+++ b/lang/python/numpy/patches/001-unpin-build-dependencies.patch
@@ -1,13 +1,16 @@
--- a/pyproject.toml
+++ b/pyproject.toml
-@@ -1,8 +1,8 @@
- [build-system]
- # Minimum requirements for the build system to execute.
+@@ -4,11 +4,11 @@
+ #build-backend = "mesonpy"
requires = [
+ # setuptools, wheel and Cython are needed for the setup.py based build
- "setuptools==59.2.0",
-- "wheel==0.37.0",
+ "setuptools>=59.2.0",
-+ "wheel>=0.37.0",
- "Cython>=0.29.30,<3.0",
+ # `wheel` is needed for non-isolated builds, given that `meson-python`
+ # doesn't list it as a runtime requirement (at least in 0.11.0) - it's
+ # likely to be removed as a dependency in meson-python 0.12.0.
+- "wheel==0.38.1",
++ "wheel>=0.38.1",
+ "Cython>=0.29.34,<3.0",
+ # "meson-python>=0.10.0",
]
-
diff --git a/lang/python/numpy/patches/002-avoid-build-user-config-files.patch b/lang/python/numpy/patches/002-avoid-build-user-config-files.patch
index 15c76e3dc..cf7faf4ed 100644
--- a/lang/python/numpy/patches/002-avoid-build-user-config-files.patch
+++ b/lang/python/numpy/patches/002-avoid-build-user-config-files.patch
@@ -1,6 +1,6 @@
--- a/numpy/distutils/system_info.py
+++ b/numpy/distutils/system_info.py
-@@ -400,7 +400,7 @@ def get_standard_file(fname):
+@@ -403,7 +403,7 @@ def get_standard_file(fname):
pass
else:
user_file = os.path.join(f, fname)