aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-01 22:45:40 -0700
committerGitHub <noreply@github.com>2020-07-01 22:45:40 -0700
commitd51084aa75805c02700d4ab005c7e312f757c066 (patch)
treed470d07d96246d338432cae4801b60cd6afdd39b
parent8d5bf278683471d84c84d4e5c34abe2475c6a840 (diff)
parentc6212ea6e9777ea5a7847ef3c91e52bcd89fdafb (diff)
Merge pull request #12683 from neheb/minic
minicom: fix compilation with GCC10
-rw-r--r--utils/minicom/Makefile2
-rw-r--r--utils/minicom/patches/200-gcc10.patch30
2 files changed, 31 insertions, 1 deletions
diff --git a/utils/minicom/Makefile b/utils/minicom/Makefile
index 5376eeb70..f21650191 100644
--- a/utils/minicom/Makefile
+++ b/utils/minicom/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=minicom
PKG_VERSION:=2.7.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://alioth.debian.org/frs/download.php/file/4215
diff --git a/utils/minicom/patches/200-gcc10.patch b/utils/minicom/patches/200-gcc10.patch
new file mode 100644
index 000000000..6c36c619c
--- /dev/null
+++ b/utils/minicom/patches/200-gcc10.patch
@@ -0,0 +1,30 @@
+--- a/src/minicom.h
++++ b/src/minicom.h
+@@ -109,13 +109,13 @@ EXTERN char *dial_tty; /* tty to use. */
+
+ EXTERN char *dial_name; /* System we're conneced to */
+ EXTERN char *dial_number; /* Number we've dialed. */
+-EXTERN char *dial_user; /* Our username there */
+-EXTERN char *dial_pass; /* Our password */
++extern char *dial_user; /* Our username there */
++extern char *dial_pass; /* Our password */
+
+ #ifdef USE_SOCKET
+-EXTERN int portfd_is_socket; /* File descriptor is a unix socket */
+-EXTERN int portfd_is_connected; /* 1 if the socket is connected */
+-EXTERN struct sockaddr_un portfd_sock_addr; /* the unix socket address */
++extern int portfd_is_socket; /* File descriptor is a unix socket */
++extern int portfd_is_connected; /* 1 if the socket is connected */
++extern struct sockaddr_un portfd_sock_addr; /* the unix socket address */
+ #define portfd_connected ((portfd_is_socket && !portfd_is_connected) \
+ ? -1 : portfd)
+ #else
+@@ -141,7 +141,7 @@ EXTERN int sbcolor; /* Status Bar Background Color */
+ EXTERN int st_attr; /* Status Bar attributes. */
+
+ /* jl 04.09.97 conversion tables */
+-EXTERN unsigned char vt_outmap[256], vt_inmap[256];
++extern unsigned char vt_outmap[256], vt_inmap[256];
+
+ /* MARK updated 02/17/95 - history buffer */
+ EXTERN int num_hist_lines; /* History buffer size */