aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-22 20:12:01 -0700
committerRosen Penev <rosenp@gmail.com>2020-04-25 15:54:14 -0700
commitd4cdc14e0e9ee16e36f1742a6943c98c1bda9cc4 (patch)
tree274cbf7057f704036f4973862ada5aa439917248
parent9c95fedca3d22b01c28dda7c72e70dfec9ca0f2e (diff)
avahi: fix dbus issue
Needs an extra configure parameter. Reverted pkgconfig fix. It's wrong anyway. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/avahi/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/libs/avahi/Makefile b/libs/avahi/Makefile
index 67aa0c804..428493c56 100644
--- a/libs/avahi/Makefile
+++ b/libs/avahi/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=avahi
PKG_VERSION:=0.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/lathiat/avahi/releases/download/v$(PKG_VERSION) \
@@ -289,6 +289,7 @@ CONFIGURE_ARGS += \
--with-distro=none \
--with-avahi-user=nobody \
--with-avahi-group=nogroup \
+ --with-avahi-priv-access-group=nogroup \
--with-autoipd-user=nobody \
--with-autoipd-group=nogroup
@@ -321,9 +322,11 @@ endif
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
$(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/avahi-core.pc
+ifeq ($(BUILD_VARIANT),dbus)
+ifneq ($(CONFIG_PACKAGE_libavahi-client),)
$(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/avahi-client.pc
+endif
ifneq ($(CONFIG_PACKAGE_libavahi-compat-libdnssd),)
-ifeq ($(BUILD_VARIANT),dbus)
$(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/avahi-compat-libdns_sd.pc
endif
endif