aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-01 22:08:40 -0700
committerGitHub <noreply@github.com>2021-06-01 22:08:40 -0700
commitd49f59cfc5471096322c038e5b5ce043ced7339a (patch)
treed71960f7a50b184dbbc48b69fe304ec3004a6420
parent63f1db006699fd00b6723cb536f05b5f911d59bb (diff)
parent12b4ab34913ec42c3a672f789093a7319636add9 (diff)
Merge pull request #15726 from stangri/master-https-dns-proxy
https-dns-proxy: 2021-05-14 bugfix: fallback to HTTP/1 by default
-rw-r--r--net/https-dns-proxy/Makefile2
-rwxr-xr-xnet/https-dns-proxy/files/https-dns-proxy.init2
-rw-r--r--net/https-dns-proxy/patches/010-ninja.patch23
3 files changed, 2 insertions, 25 deletions
diff --git a/net/https-dns-proxy/Makefile b/net/https-dns-proxy/Makefile
index 887c13a01..cddd567bf 100644
--- a/net/https-dns-proxy/Makefile
+++ b/net/https-dns-proxy/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=https-dns-proxy
PKG_VERSION:=2021-05-14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy
diff --git a/net/https-dns-proxy/files/https-dns-proxy.init b/net/https-dns-proxy/files/https-dns-proxy.init
index 8b8680763..6b7486fae 100755
--- a/net/https-dns-proxy/files/https-dns-proxy.init
+++ b/net/https-dns-proxy/files/https-dns-proxy.init
@@ -56,7 +56,7 @@ start_instance() {
append_parm "$cfg" 'group' '-g' 'nogroup'
append_parm "$cfg" 'proxy_server' '-t'
append_parm "$cfg" 'logfile' '-l'
- append_bool "$cfg" 'use_http1' '-x'
+ append_bool "$cfg" 'use_http1' '-x' '1'
config_get_bool ipv6_resolvers_only "$cfg" 'use_ipv6_resolvers_only' '0'
config_get verbosity "$cfg" 'verbosity' '0'
diff --git a/net/https-dns-proxy/patches/010-ninja.patch b/net/https-dns-proxy/patches/010-ninja.patch
deleted file mode 100644
index ffe108350..000000000
--- a/net/https-dns-proxy/patches/010-ninja.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/src/logging.h
-+++ b/src/logging.h
-@@ -36,6 +36,20 @@ enum _LogSeverity {
- LOG_MAX
- };
-
-+#define STRIPPATH(s)\
-+ (sizeof(s) > 2 && (s)[sizeof(s)-2] == '/' ? (s) + sizeof(s) - 1 : \
-+ sizeof(s) > 3 && (s)[sizeof(s)-3] == '/' ? (s) + sizeof(s) - 2 : \
-+ sizeof(s) > 4 && (s)[sizeof(s)-4] == '/' ? (s) + sizeof(s) - 3 : \
-+ sizeof(s) > 5 && (s)[sizeof(s)-5] == '/' ? (s) + sizeof(s) - 4 : \
-+ sizeof(s) > 6 && (s)[sizeof(s)-6] == '/' ? (s) + sizeof(s) - 5 : \
-+ sizeof(s) > 7 && (s)[sizeof(s)-7] == '/' ? (s) + sizeof(s) - 6 : \
-+ sizeof(s) > 8 && (s)[sizeof(s)-8] == '/' ? (s) + sizeof(s) - 7 : \
-+ sizeof(s) > 9 && (s)[sizeof(s)-9] == '/' ? (s) + sizeof(s) - 8 : \
-+ sizeof(s) > 10 && (s)[sizeof(s)-10] == '/' ? (s) + sizeof(s) - 9 : \
-+ sizeof(s) > 11 && (s)[sizeof(s)-11] == '/' ? (s) + sizeof(s) - 10 : (s))
-+
-+#define __FILENAME__ STRIPPATH(__FILE__)
-+
- #define DLOG(...) _log(__FILENAME__, __LINE__, LOG_DEBUG, __VA_ARGS__)
- #define ILOG(...) _log(__FILENAME__, __LINE__, LOG_INFO, __VA_ARGS__)
- #define WLOG(...) _log(__FILENAME__, __LINE__, LOG_WARNING, __VA_ARGS__)