aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmr Hassan <amr.hassan@codescalers.com>2015-02-22 15:55:07 +0200
committerAmr Hassan <amr.hassan@gmail.com>2015-03-01 15:04:15 +0200
commitd4969a644c516c1dbdbc541d051437e2d12da51e (patch)
tree9cbaeda14ba85a6313444f2b7f7cfcac028983c9
parentc36bc9cee05ad01ea6b51b4976b61ce2f154e056 (diff)
JSON4Lua: Add new package
Signed-off-by: Amr Hassan <amr.hassan@gmail.com>
-rw-r--r--lang/json4lua/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/lang/json4lua/Makefile b/lang/json4lua/Makefile
new file mode 100644
index 000000000..ff8774cf1
--- /dev/null
+++ b/lang/json4lua/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=json4lua
+PKG_VERSION:=0.9.53
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/amrhassan/$(PKG_NAME)/archive/
+PKG_MAINTAINER:=Amr Hassan <amr.hassan@gmail.com>
+PKG_LICENSE=MIT
+
+LUA_MODULE_PATH:=/usr/lib/lua
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/json4lua
+ SUBMENU:=Lua
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=json4lua
+ URL:=https://github.com/amrhassan/json4lua
+ DEPENDS:=+lua +luasocket
+endef
+
+define Package/json4lua/description
+ JSON and JSONRPC for Lua
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/json4lua/install
+ $(INSTALL_DIR) $(1)/$(LUA_MODULE_PATH)/json
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/json/json.lua $(1)/$(LUA_MODULE_PATH)/json.lua
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/json/rpc.lua $(1)/$(LUA_MODULE_PATH)/json/rpc.lua
+endef
+
+$(eval $(call BuildPackage,json4lua))