aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.net>2020-06-26 03:09:26 +0000
committerStan Grishin <stangri@melmac.net>2020-06-26 03:09:26 +0000
commitd2f4454fe61caccefecc28f8add8f6d4219b5bb5 (patch)
tree3943e25f13af1d81598bfeabba5008c04b71e13f
parentb867631f7cde40cc2cdd65343936e931a315bd7a (diff)
https-dns-proxy: re-add conffiles and add description to Makefile
Signed-off-by: Stan Grishin <stangri@melmac.net>
-rw-r--r--net/https-dns-proxy/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/net/https-dns-proxy/Makefile b/net/https-dns-proxy/Makefile
index 61ee5b42d..bb820b789 100644
--- a/net/https-dns-proxy/Makefile
+++ b/net/https-dns-proxy/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=https-dns-proxy
PKG_VERSION:=2020-04-09
-PKG_RELEASE=2
+PKG_RELEASE=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy
@@ -26,6 +26,15 @@ define Package/https-dns-proxy
CONFLICTS:=https_dns_proxy
endef
+define Package/https-dns-proxy/description
+https_dns_proxy is a light-weight DNS<-->HTTPS, non-caching translation proxy for the RFC 8484 DNS-over-HTTPS standard. It receives regular (UDP) DNS requests and issues them via DoH.
+Please see https://github.com/openwrt/packages/blob/master/net/https-dns-proxy/files/README.md for further information.
+endef
+
+define Package/https-dns-proxy/conffiles
+/etc/config/https-dns-proxy
+endef
+
define Package/https-dns-proxy/install
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d ${1}/etc/config
$(INSTALL_BIN) $(PKG_BUILD_DIR)/https_dns_proxy $(1)/usr/sbin/https-dns-proxy