aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2020-08-04 14:28:06 +0200
committerJan Pavlinec <jan.pavlinec@nic.cz>2020-08-24 12:37:35 +0200
commitd0ef2feda1621ccd8c1187ff509d3100cc075e9a (patch)
tree60fbcd3450dc6d8c9fa31674dbafaf895487c3fc
parentc158c02bc5f38cebff1bb523df9ca9b6bfc958cb (diff)
python-toml: add new package (pytest dependency)
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
-rw-r--r--lang/python/python-toml/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/lang/python/python-toml/Makefile b/lang/python/python-toml/Makefile
new file mode 100644
index 000000000..5ee5c5411
--- /dev/null
+++ b/lang/python/python-toml/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-toml
+PKG_VERSION:=0.10.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=toml
+PKG_HASH:=926b612be1e5ce0634a2ca03470f95169cf16f939018233a670519cb4ac58b0f
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-toml
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=A Python library for parsing and creating TOML
+ URL:=https://github.com/uiri/toml
+ DEPENDS:= +python3-light +python3-decimal
+endef
+
+define Package/python3-toml/description
+ Python Library for Tom's Obvious, Minimal Language
+endef
+
+$(eval $(call Py3Package,python3-toml))
+$(eval $(call BuildPackage,python3-toml))
+$(eval $(call BuildPackage,python3-toml-src))