aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2016-06-04 08:36:47 +0200
committerDirk Brenken <dev@brenken.org>2016-06-04 08:36:47 +0200
commitd0eceb6b2540bf5c06a0405245803052d032a82e (patch)
tree9b934cd4bf5fd54ada9a61e224a562253306912c
parent26fa1c5df070d7cbbe24791ba0696e035d01cdde (diff)
adblock: update 1.1.17
* change winspy url again * various cosmetics left out in former release Signed-off-by: Dirk Brenken <dev@brenken.org>
-rw-r--r--net/adblock/Makefile4
-rw-r--r--net/adblock/files/README.md7
-rw-r--r--net/adblock/files/adblock-helper.sh6
-rwxr-xr-xnet/adblock/files/adblock-update.sh13
-rw-r--r--net/adblock/files/adblock.conf4
-rwxr-xr-xnet/adblock/files/adblock.init11
6 files changed, 20 insertions, 25 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index 4fa8fdf51..21fe36b46 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -7,8 +7,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
-PKG_VERSION:=1.1.16
-PKG_RELEASE:=2
+PKG_VERSION:=1.1.17
+PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/README.md b/net/adblock/files/README.md
index 86fcb208b..adb3eb912 100644
--- a/net/adblock/files/README.md
+++ b/net/adblock/files/README.md
@@ -39,7 +39,7 @@ A lot of people already use adblocker plugins within their desktop browsers, but
* => weekly updates, approx. 12.000 entries
* [winhelp](http://winhelp2002.mvps.org)
* => infrequent updates, approx. 15.000 entries
- * [winspy](https://raw.githubusercontent.com/crazy-max/WindowsSpyBlocker/master/hosts/windows10_spy.txt)
+ * [winspy](https://github.com/crazy-max/WindowsSpyBlocker)
* => infrequent updates, approx. 120 entries
* [yoyo](http://pgl.yoyo.org/adservers)
* => weekly updates, approx. 2.500 entries (enabled by default)
@@ -102,8 +102,9 @@ A lot of people already use adblocker plugins within their desktop browsers, but
* **list updates:** for a scheduled call of the adblock service add an appropriate crontab entry (see example below)
* **new list sources:** you could add new blocklist sources on your own via uci config, all you need is a source url and an awk one-liner (see example below)
* **AP mode:** in AP mode adblock uses automatically the local router ip as nullip address. To make sure that your LuCI interface will be still accessible, please change the local uhttpd instance to ports <> 80/443 (see example below)
+* **Restricted mode:** to disable flash writes with adblock status information to the adblock config file (used by LuCI frontend), please set 'adb\_restricted' to '1'
* **adblock toggle:** to quickly switch adblocking 'on' or 'off', simply use _/etc/init.d/adblock toggle_
-* **outdated configuration:** to update an outdated adblock config file, please use _/etc/init.d/adblock cfgup_, make your individual changes and restart the adblock service
+* **configuration update:** to update an outdated adblock config file with the current default version, please run _/etc/init.d/adblock cfgup_, make your individual changes and start the adblock service again
* **debugging:** for script debugging please set the 'adb\_debug' variable in the header of _/etc/init.d/adblock_ to '1'
* **disable active dns probing in windows:** to prevent a possible yellow exclamation mark on your internet connection icon (which wrongly means connected, but no internet), please change the following registry key/value from "1" to "0" _HKLM\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing_
@@ -115,7 +116,7 @@ A lot of people already use adblocker plugins within their desktop browsers, but
* adb\_nullport => port of the adblock uhttpd instance (default: '65535')
* adb\_nullipv4 => IPv4 blackhole ip address (default: '192.0.2.1', in AP mode: local router ip)
* adb\_nullipv6 => IPv6 blackhole ip address (default: '::ffff:c000:0201', in AP mode: local router ip)
- * adb\_forcedns => redirect all DNS queries to local dnsmasq resolver (default: '1', enabled)
+ * adb\_forcedns => redirect all local DNS queries to the local dnsmasq resolver (default: '1', enabled)
* adb\_fetchttl => set the timeout for list downloads (default: '5' seconds)
* adb\_restricted => disable updates of the adblock config file (no flash writes) during runtime (default: '0', disabled)
diff --git a/net/adblock/files/adblock-helper.sh b/net/adblock/files/adblock-helper.sh
index c6ebc271c..f447c99f8 100644
--- a/net/adblock/files/adblock-helper.sh
+++ b/net/adblock/files/adblock-helper.sh
@@ -142,7 +142,7 @@ f_envload()
# check running dnsmasq instance
#
- check="$(ps | pgrep -f "dnsmasq")"
+ check="$(pgrep -f "dnsmasq")"
if [ -z "${check}" ]
then
rc=-1
@@ -389,7 +389,7 @@ f_envcheck()
# check volatile adblock uhttpd instance configuration
#
- check="$(ps | pgrep -f "uhttpd -h /www/adblock")"
+ check="$(pgrep -f "uhttpd -h /www/adblock")"
if [ -z "${check}" ]
then
if [ -n "${adb_wanif4}" ] && [ -n "${adb_wanif6}" ]
@@ -617,7 +617,7 @@ f_restore()
then
/etc/init.d/dnsmasq restart
sleep 1
- check="$(ps | pgrep -f "dnsmasq")"
+ check="$(pgrep -f "dnsmasq")"
if [ -n "${check}" ]
then
rc=0
diff --git a/net/adblock/files/adblock-update.sh b/net/adblock/files/adblock-update.sh
index b5dbed9e1..6421e47c6 100755
--- a/net/adblock/files/adblock-update.sh
+++ b/net/adblock/files/adblock-update.sh
@@ -10,13 +10,6 @@
#
LC_ALL=C
-# quiet output if 'adb_debug' not set
-#
-if [ -z "${adb_debug}" ]
-then
- exec 2>/dev/null
-fi
-
# set pid & logger
#
adb_pid="${$}"
@@ -35,8 +28,8 @@ fi
# get current directory and set script/config version
#
adb_scriptdir="${0%/*}"
-adb_scriptver="1.1.16"
-adb_mincfgver="2.0"
+adb_scriptver="1.1.17"
+adb_mincfgver="2.1"
# source in adblock function library
#
@@ -301,7 +294,7 @@ then
"${adb_uci}" -q set "adblock.global.adb_dnstoggle=on"
/etc/init.d/dnsmasq restart
sleep 1
- check="$(ps | pgrep -f "dnsmasq")"
+ check="$(pgrep -f "dnsmasq")"
if [ -n "${check}" ]
then
f_log "adblock lists with overall ${adb_count} domains loaded"
diff --git a/net/adblock/files/adblock.conf b/net/adblock/files/adblock.conf
index de4c2fb93..be656d677 100644
--- a/net/adblock/files/adblock.conf
+++ b/net/adblock/files/adblock.conf
@@ -3,7 +3,7 @@
config adblock 'global'
option adb_enabled '1'
- option adb_cfgver '2.0'
+ option adb_cfgver '2.1'
option adb_whitelist '/etc/adblock/adblock.whitelist'
option adb_whitelist_rset '\$1 ~/^([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\$1)}'
option adb_forcedns '1'
@@ -115,7 +115,7 @@ config source 'whocares'
config source 'winspy'
option enabled '0'
- option adb_src 'https://raw.githubusercontent.com/crazy-max/WindowsSpyBlocker/master/hosts/windows10_spy.txt'
+ option adb_src 'https://raw.githubusercontent.com/crazy-max/WindowsSpyBlocker/master/data/hosts/win10/spy.txt'
option adb_src_rset '\$0 ~/^0\.0\.0\.0[ \t]+([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\$2)}'
option adb_src_desc 'focus on windows spy & telemetry domains, infrequent updates, approx. 120 entries'
diff --git a/net/adblock/files/adblock.init b/net/adblock/files/adblock.init
index e27a3fd16..7c63213e7 100755
--- a/net/adblock/files/adblock.init
+++ b/net/adblock/files/adblock.init
@@ -21,10 +21,6 @@ adb_dnsprefix="adb_list"
adb_pidfile="/var/run/adblock.pid"
adb_log="$(which logger)"
adb_uci="$(which uci)"
-if [ "$(${adb_uci} -q get "adblock.global.adb_restricted")" = "1" ]
-then
- adb_uci="$(which true)"
-fi
if [ -t 1 ]
then
@@ -96,7 +92,7 @@ stop()
/etc/init.d/dnsmasq restart
/etc/init.d/firewall restart
fi
- uhttpd_pid="$(ps | pgrep -f "uhttpd -h /www/adblock")"
+ uhttpd_pid="$(pgrep -f "uhttpd -h /www/adblock")"
if [ -n "${uhttpd_pid}" ]
then
kill -9 "${uhttpd_pid}"
@@ -110,6 +106,10 @@ stop()
toggle()
{
+ if [ "$(${adb_uci} -q get "adblock.global.adb_restricted")" = "1" ]
+ then
+ adb_uci="$(which true)"
+ fi
if [ -d "${adb_dnshidedir}" ]
then
list_dns="$(find "${adb_dnsdir}" -maxdepth 1 -type f -name "${adb_dnsprefix}*" -print)"
@@ -130,6 +130,7 @@ toggle()
"${adb_log}" ${log_parm} -t "adblock[${adb_pid}] info " "toggle for adblocking switched 'on'" 2>&1
fi
fi
+ return 0
}
cfgup()