aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2017-07-17 10:52:44 -0400
committerGitHub <noreply@github.com>2017-07-17 10:52:44 -0400
commitd0708338eee922a582b1a3c8b702e8783a222d90 (patch)
tree1acda54c3940c488be0c017062397551eb136ea7
parentb8bc3fe3f5871bdcd75991cedb542f13221cb65e (diff)
parent08e74f346afa8b65c1661d531e25d3a3334a6d3c (diff)
Merge pull request #4577 from diizzyy/patch-66
sound/mocp: General cleanup
-rw-r--r--sound/mocp/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/sound/mocp/Makefile b/sound/mocp/Makefile
index 93f9c6faf..8860ce195 100644
--- a/sound/mocp/Makefile
+++ b/sound/mocp/Makefile
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=moc
PKG_VERSION:=2.5.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ftp.daper.net/pub/soft/moc/stable/
-PKG_MD5SUM:=f3a68115602a4788b7cfa9bbe9397a9d5e24c68cb61a57695d1c2c3ecf49db08
+PKG_HASH:=f3a68115602a4788b7cfa9bbe9397a9d5e24c68cb61a57695d1c2c3ecf49db08
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
@@ -29,7 +29,7 @@ include $(INCLUDE_DIR)/nls.mk
define Package/moc
SECTION:=sound
CATEGORY:=Sound
- DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-lib +libid3tag +libflac +libsamplerate +libncursesw +libffmpeg +libltdl +libmagic +faad2 +libdb47
+ DEPENDS:=+libcurl $(ICONV_DEPENDS) +alsa-lib +libid3tag +libsamplerate +libncursesw +libffmpeg +libltdl +libmagic +libdb47
TITLE:=Music On Console
URL:=http://moc.daper.net/
endef
@@ -43,16 +43,18 @@ TARGET_CFLAGS+=-D_GNU_SOURCE
TARGET_CPPFLAGS+=-P
CONFIGURE_ARGS+= \
- $(if $(CONFIG_BUILD_PATENTED),,--without-mp3) \
--enable-shared \
--disable-static \
--disable-debug \
--without-speex \
- --without-samplerate \
- --without-curl \
+ --without-aac \
--without-flac \
+ --without-mp3 \
--without-musepack \
--without-rcc \
+ --without-sndfile \
+ --without-vorbis \
+ --without-wavpack \
$(if $(CONFIG_PACKAGE_libncursesw),--with-ncursesw --without-ncurses,--with-ncurses --without-ncursesw) \
--with-bdb-dir="$(STAGING_DIR)/usr"