aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-08 22:39:28 -0700
committerRosen Penev <rosenp@gmail.com>2019-05-13 14:12:14 -0700
commitcfd47f5da1c378c0b76aa35ced2489134f7b92e5 (patch)
treed83b9a51c1b2319070d20774d792c0eb189e90f6
parent65ca405328176d44d8fbaf32f0e6e0de2e80dafe (diff)
powertop: Switch to uClibc++
Now that the uClibc++ update has been included, we can switch to it. Basic testing shows it as working. Also fixed compilation with uClibc-ng. libiconv-stub must be used as uClibc-ng does not provide those headers. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/powertop/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/utils/powertop/Makefile b/utils/powertop/Makefile
index 430ce693b..15a5881e4 100644
--- a/utils/powertop/Makefile
+++ b/utils/powertop/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=powertop
PKG_VERSION:=2.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://01.org/sites/default/files/downloads/
@@ -22,12 +22,14 @@ PKG_LICENSE:=GPL-2.0
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
define Package/powertop
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+libpci +libncursesw +libnl-genl +libstdcpp
+ DEPENDS:=$(CXX_DEPENDS) $(INTL_DEPENDS) +libpci +libncursesw +libnl-genl
TITLE:=Power consumption monitor
URL:=https://01.org/powertop
endef
@@ -37,6 +39,8 @@ define Package/powertop/description
and power management.
endef
+TARGET_LDFLAGS += $(if $(INTL_FULL),-lintl)
+
define Package/powertop/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/powertop \