aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Ardelean <aa@ocedo.com>2014-09-18 11:24:43 +0300
committerAlexandru Ardelean <aa@ocedo.com>2014-09-18 17:21:58 +0300
commitcf5fdf8a8fd4f55f549a482b00d0bd7d59806890 (patch)
tree00ca660b50f26da8dda3cf207c64082ac4cc4266
parent4940679ef2923f85bb2bc14bb9540b5fa80c8833 (diff)
openvswitch: change order of the installs
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
-rw-r--r--net/openvswitch/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 6a199f22f..05a46510e 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -123,16 +123,6 @@ define Build/Compile
KCC="$(KERNEL_CC)"
endef
-define Package/openvswitch-ipsec/install
- $(INSTALL_DIR) $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/debian/ovs-monitor-ipsec $(1)/usr/sbin/
-endef
-
-define Package/openvswitch-benchmark/install
- $(INSTALL_DIR) $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-benchmark $(1)/usr/bin/
-endef
-
define Package/openvswitch/install
$(INSTALL_DIR) $(1)/etc/openvswitch
@@ -162,6 +152,16 @@ define Package/openvswitch/install
$(INSTALL_CONF) $(PKG_BUILD_DIR)/vswitchd/vswitch.ovsschema $(1)/usr/share/openvswitch/
endef
+define Package/openvswitch-ipsec/install
+ $(INSTALL_DIR) $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/debian/ovs-monitor-ipsec $(1)/usr/sbin/
+endef
+
+define Package/openvswitch-benchmark/install
+ $(INSTALL_DIR) $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-benchmark $(1)/usr/bin/
+endef
+
define Package/openvswitch/postinst
#!/bin/sh
[ -n "$${IPKG_INSTROOT}" ] || /etc/init.d/openvswitch enable || true