aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2015-09-29 00:04:02 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2015-09-29 00:04:02 +0200
commitcf18ddf0a2e4aee2257fd34f5312280181b978d9 (patch)
tree00662005488874aa55702c3653271813ee398db5
parenta4a2963af8c2fb7830fd78d5b0451abc43f866aa (diff)
dump1090: switch to mutability repo, make view1090 a separate package
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
-rw-r--r--utils/dump1090/Config.in20
-rw-r--r--utils/dump1090/Makefile52
-rw-r--r--utils/dump1090/files/dump1090.config16
-rw-r--r--utils/dump1090/files/dump1090.init18
-rw-r--r--utils/dump1090/patches/100-html_dir.patch11
5 files changed, 58 insertions, 59 deletions
diff --git a/utils/dump1090/Config.in b/utils/dump1090/Config.in
deleted file mode 100644
index cee0aa5db..000000000
--- a/utils/dump1090/Config.in
+++ /dev/null
@@ -1,20 +0,0 @@
-config DUMP1090_DUMP
- bool "dump1090"
- depends on PACKAGE_dump1090
- default y
- help
- dump1090 ModeS Receiver
-
-config DUMP1090_WWW
- bool "website files"
- depends on DUMP1090_DUMP
- default y
- help
- HTML website files for showing planes
-
-config DUMP1090_VIEW
- bool "view1090"
- depends on PACKAGE_dump1090
- default n
- help
- view1090 dump1090 Viewer
diff --git a/utils/dump1090/Makefile b/utils/dump1090/Makefile
index 82ce06a67..23a065c01 100644
--- a/utils/dump1090/Makefile
+++ b/utils/dump1090/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013-2014 OpenWrt.org
+# Copyright (C) 2013-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,63 +8,65 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dump1090
-PKG_VERSION:=2014-11-09
+PKG_VERSION:=2015-09-28
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://github.com/MalcolmRobb/dump1090.git
+PKG_SOURCE_URL:=git://github.com/mutability/dump1090.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=bff92c4ad772a0a8d433f788d39dae97e00e4dbe
+PKG_SOURCE_VERSION:=3b4c872ea67118de1399ba9979e71b504a36aca8
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
-PKG_LICENSE:=BSD-3c
-
-PKG_CONFIG_DEPENDS:= \
- CONFIG_DUMP1090_DUMP \
- CONFIG_DUMP1090_WWW \
- CONFIG_DUMP1090_VIEW
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING,LICENSE
include $(INCLUDE_DIR)/package.mk
-define Package/dump1090
+define Package/dump1090/Default
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Mode S decoder for the Realtek RTL2832U
- URL:=https://github.com/MalcolmRobb/dump1090
+ URL:=https://github.com/mutability/dump1090
DEPENDS:=+libpthread +librtlsdr
endef
-define Package/dump1090/config
- source "$(SOURCE)/Config.in"
+define Package/dump1090
+ $(call Package/dump1090/Default)
+ TITLE+= (dump1090)
+endef
+
+define Package/view1090
+ $(call Package/dump1090/Default)
+ TITLE+= (view1090)
endef
define Package/dump1090/description
Dump1090 is a Mode S decoder specifically designed for RTLSDR devices.
- Embedded HTTP server that displays the currently detected aircrafts on
- Google Maps. Network output in Basestation and AVR formats.
+endef
+
+define Package/view1090/description
+ View1090 is a Mode S messages viewer for dump1090 devices.
endef
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)"
define Package/dump1090/install
- $(INSTALL_DIR) $(1)/usr/bin
-
-ifneq ($(CONFIG_DUMP1090_DUMP),)
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) files/dump1090.init $(1)/etc/init.d/dump1090
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) files/dump1090.config $(1)/etc/config/dump1090
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/dump1090 $(1)/usr/bin
-ifneq ($(CONFIG_DUMP1090_WWW),)
$(INSTALL_DIR) $(1)/usr/share/dump1090
$(CP) $(PKG_BUILD_DIR)/public_html/* $(1)/usr/share/dump1090
-endif
-endif
-ifneq ($(CONFIG_DUMP1090_VIEW),)
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/dump1090 $(1)/usr/bin
+endef
+
+define Package/view1090/install
+ $(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/view1090 $(1)/usr/bin
-endif
endef
$(eval $(call BuildPackage,dump1090))
+$(eval $(call BuildPackage,view1090))
diff --git a/utils/dump1090/files/dump1090.config b/utils/dump1090/files/dump1090.config
index 53d40ef7f..8fd6d4295 100644
--- a/utils/dump1090/files/dump1090.config
+++ b/utils/dump1090/files/dump1090.config
@@ -6,6 +6,8 @@ config dump1090 main
option enable_agc '0'
option freq ''
option ifile ''
+ option iformat ''
+ option throttle '0'
option raw '0'
option net '1'
option modeac '0'
@@ -18,12 +20,16 @@ config dump1090 main
option net_sbs_port ''
option net_bi_port ''
option net_bo_port ''
+ option net_fatsv_port ''
option net_ro_size ''
- option net_ro_rate ''
+ option net_ro_interval ''
option net_heartbeat ''
option net_buffer ''
+ option net_verbatim '0'
+ option forward_mlat '0'
option lat ''
option lon ''
+ option max_range ''
option fix '0'
option no_fix '0'
option no_crc_check '0'
@@ -31,9 +37,17 @@ config dump1090 main
option agressive '0'
option mlat '0'
option stats '0'
+ option stats_range '0'
option stats_every ''
option onlyaddr '0'
option metric '0'
option snip ''
option debug ''
option ppm ''
+ option html_dir '/usr/share/dump1090'
+ option write_json ''
+ option write_json_every ''
+ option json_location_accuracy ''
+ option oversample '0'
+ option dcfilter '0'
+ option measure_noise '0'
diff --git a/utils/dump1090/files/dump1090.init b/utils/dump1090/files/dump1090.init
index bc0755fb8..8a3e2b233 100644
--- a/utils/dump1090/files/dump1090.init
+++ b/utils/dump1090/files/dump1090.init
@@ -1,5 +1,5 @@
#!/bin/sh /etc/rc.common
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014-2015 OpenWrt.org
START=90
STOP=10
@@ -44,6 +44,8 @@ start_instance() {
append_bool "$cfg" enable_agc "--enable-agc"
append_arg "$cfg" freq "--freq"
append_arg "$cfg" ifile "--ifile"
+ append_arg "$cfg" iformat "--iformat"
+ append_bool "$cfg" throttle "--throttle"
append_bool "$cfg" raw "--raw"
append_bool "$cfg" net "--net"
append_bool "$cfg" modeac "--modeac"
@@ -56,12 +58,16 @@ start_instance() {
append_arg "$cfg" net_sbs_port "--net-sbs-port"
append_arg "$cfg" net_bi_port "--net-bi-port"
append_arg "$cfg" net_bo_port "--net-bo-port"
+ append_arg "$cfg" net_fatsv_port "net-fatsv-port"
append_arg "$cfg" net_ro_size "--net-ro-size"
- append_arg "$cfg" net_ro_rate "--net-ro-rate"
+ append_arg "$cfg" net_ro_interval "--net-ro-interval"
append_arg "$cfg" net_heartbeat "--net-heartbeat"
append_arg "$cfg" net_buffer "--net-buffer"
+ append_bool "$cfg" net_verbatim "--net-verbatim"
+ append_bool "$cfg" forward_mlat "--forward-mlat"
append_arg "$cfg" lat "--lat"
append_arg "$cfg" lon "--lon"
+ append_arg "$cfg" max_range "--max-range"
append_bool "$cfg" fix "--fix"
append_bool "$cfg" no_fix "--no-fix"
append_bool "$cfg" no_crc_check "--no-crc-check"
@@ -69,12 +75,20 @@ start_instance() {
append_bool "$cfg" agressive "--agressive"
append_bool "$cfg" mlat "--mlat"
append_bool "$cfg" stats "--stats"
+ append_bool "$cfg" stats_range "--stats-range"
append_arg "$cfg" stats_every "--stats-every"
append_bool "$cfg" onlyaddr "--onlyaddr"
append_bool "$cfg" metric "--metric"
append_arg "$cfg" snip "--snip"
append_arg "$cfg" debug "--debug"
append_arg "$cfg" ppm "--ppm"
+ append_arg "$cfg" html_dir "--html-dir"
+ append_arg "$cfg" write_json "--write-json"
+ append_arg "$cfg" write_json_every "write-json-every"
+ append_arg "$cfg" json_location_accuracy "--json-location-accuracy"
+ append_bool "$cfg" oversample "--oversample"
+ append_bool "$cfg" dcfilter "--dcfilter"
+ append_bool "$cfg" measure_noise "--measure-noise"
config_get_bool aux "$cfg" 'respawn' '0'
[ "$aux" = 1 ] && procd_set_param respawn
diff --git a/utils/dump1090/patches/100-html_dir.patch b/utils/dump1090/patches/100-html_dir.patch
deleted file mode 100644
index 8976057f7..000000000
--- a/utils/dump1090/patches/100-html_dir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/dump1090.h
-+++ b/dump1090.h
-@@ -178,7 +178,7 @@
- #define MODES_NET_SNDBUF_MAX (7)
-
- #ifndef HTMLPATH
--#define HTMLPATH "./public_html" // default path for gmap.html etc
-+#define HTMLPATH "/usr/share/dump1090" // default path for gmap.html etc
- #endif
-
- #define MODES_NOTUSED(V) ((void) V)