aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-02-07 12:51:54 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2016-02-07 12:51:54 +0200
commitcdf08481cf7b8e0ec3f867aa66e9148d959cd228 (patch)
treeed8c6e829c01689fa684c4ec4a345185435951ee
parent854bcf0e27fd30b28af83ac69b446835adbcdec6 (diff)
parentf237c2e0895a319e7c74a57ae90ceebb7230683b (diff)
Merge pull request #2352 from chris5560/radicale
Radicale: bump to version 1.1.1
-rw-r--r--net/radicale/Makefile27
-rwxr-xr-xnet/radicale/files/radicale.init2
-rw-r--r--net/radicale/files/radicale.upgrade4
3 files changed, 21 insertions, 12 deletions
diff --git a/net/radicale/Makefile b/net/radicale/Makefile
index 7e292d644..a08c62dad 100644
--- a/net/radicale/Makefile
+++ b/net/radicale/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2015 OpenWrt.org
+# Copyright (C) 2008-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
#
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=radicale
-PKG_VERSION:=1.1
+PKG_VERSION:=1.1.1
PKG_RELEASE:=1
PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
@@ -16,7 +16,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_SOURCE:=Radicale-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://pypi.python.org/packages/source/R/Radicale/
-PKG_MD5SUM:=2e3f11d05d7a21ee412dfd7bd5c38961
+PKG_MD5SUM:=a29dd538377ea24cec83237a636122ae
# needed for "r"adicale <-> "R"adicale
PKG_BUILD_DIR:=$(BUILD_DIR)/Radicale-$(PKG_VERSION)
@@ -98,16 +98,21 @@ $(call Package/$(PKG_NAME)-py2/preinst)
endef
define Package/$(PKG_NAME)-py2/install
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/radicale.init $(1)/etc/init.d/radicale
- $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/radicale.init $(1)/etc/init.d/radicale
+
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_BIN) ./files/radicale.hotplug $(1)/etc/hotplug.d/iface/80-radicale
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) ./files/radicale.config $(1)/etc/config/radicale
- $(INSTALL_DIR) $(1)/etc/radicale/ssl
- $(INSTALL_DATA) ./files/config.template $(1)/etc/radicale/
- $(INSTALL_DATA) ./files/logging.template $(1)/etc/radicale/
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/radicale.config $(1)/etc/config/radicale
+
+ $(INSTALL_DIR) $(1)/lib/upgrade/keep.d
+ $(INSTALL_DATA) ./files/radicale.upgrade $(1)/lib/upgrade/keep.d/radicale
+
+ $(INSTALL_DIR) $(1)/etc/radicale/ssl
+ $(INSTALL_DATA) ./files/config.template $(1)/etc/radicale/config.template
+ $(INSTALL_DATA) ./files/logging.template $(1)/etc/radicale/logging.template
$(INSTALL_DATA) ./files/radicale.users $(1)/etc/radicale/users
$(INSTALL_DATA) ./files/radicale.rights $(1)/etc/radicale/rights
diff --git a/net/radicale/files/radicale.init b/net/radicale/files/radicale.init
index 8b3bb4993..4fb9bbb8a 100755
--- a/net/radicale/files/radicale.init
+++ b/net/radicale/files/radicale.init
@@ -1,5 +1,5 @@
#!/bin/sh /etc/rc.common
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
START=80
STOP=10
diff --git a/net/radicale/files/radicale.upgrade b/net/radicale/files/radicale.upgrade
new file mode 100644
index 000000000..760782f6a
--- /dev/null
+++ b/net/radicale/files/radicale.upgrade
@@ -0,0 +1,4 @@
+/etc/config/radicale
+/etc/radicale/users
+/etc/radicale/rights
+