aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-06-18 20:00:51 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-06-18 20:08:26 -0700
commitcdc800874a50ab946078bcf3da859295d3ecebfa (patch)
tree3e61d09bd6e4c4f8bcca7f419d94c7d5e723f070
parentcd79492ae2700b7ab0b36148211031f6e9185f72 (diff)
zerotier: Allow building with older GCC 4.8
ZeroTier builds fine with GCC 4.8, so relax the check to make that possible. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
-rw-r--r--net/zerotier/Makefile2
-rw-r--r--net/zerotier/patches/0003-gcc48.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/net/zerotier/Makefile b/net/zerotier/Makefile
index 6284f1038..15cf30ce0 100644
--- a/net/zerotier/Makefile
+++ b/net/zerotier/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zerotier
PKG_VERSION:=1.2.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-3.0
diff --git a/net/zerotier/patches/0003-gcc48.patch b/net/zerotier/patches/0003-gcc48.patch
new file mode 100644
index 000000000..766dd5731
--- /dev/null
+++ b/net/zerotier/patches/0003-gcc48.patch
@@ -0,0 +1,13 @@
+Index: ZeroTierOne-1.2.4/ext/json/json.hpp
+===================================================================
+--- ZeroTierOne-1.2.4.orig/ext/json/json.hpp
++++ ZeroTierOne-1.2.4/ext/json/json.hpp
+@@ -64,7 +64,7 @@ SOFTWARE.
+ #endif
+ #elif defined(__GNUC__)
+ #define GCC_VERSION (__GNUC__ * 10000 + __GNUC_MINOR__ * 100 + __GNUC_PATCHLEVEL__)
+- #if GCC_VERSION < 40900
++ #if GCC_VERSION < 40800
+ #error "unsupported GCC version - see https://github.com/nlohmann/json#supported-compilers"
+ #endif
+ #endif