aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.net>2021-04-11 01:29:59 +0000
committerPaul Spooren <mail@aparcar.org>2021-04-10 16:58:51 -1000
commitcd11d8821f43eef53142476a9bbb71dd85887f4b (patch)
treefdf8ca0430b3769f0cade83c14e201c8be7ae3a8
parent05863bf273c5828763c123b5cd31516291e8c34e (diff)
https-dns-proxy: bugfix: race condition with dnsmasq
Signed-off-by: Stan Grishin <stangri@melmac.net>
-rw-r--r--net/https-dns-proxy/Makefile2
-rwxr-xr-xnet/https-dns-proxy/files/https-dns-proxy.init2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/https-dns-proxy/Makefile b/net/https-dns-proxy/Makefile
index 7413a208d..990c49588 100644
--- a/net/https-dns-proxy/Makefile
+++ b/net/https-dns-proxy/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=https-dns-proxy
PKG_VERSION:=2021-01-17
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy
diff --git a/net/https-dns-proxy/files/https-dns-proxy.init b/net/https-dns-proxy/files/https-dns-proxy.init
index c26b33c70..e83fafb49 100755
--- a/net/https-dns-proxy/files/https-dns-proxy.init
+++ b/net/https-dns-proxy/files/https-dns-proxy.init
@@ -110,7 +110,7 @@ start_service() {
procd_open_data
json_add_array firewall
for c in $forceDNSPorts; do
- if netstat -tuln | grep LISTEN | grep ":${c}" >/dev/null 2>&1; then
+ if netstat -tuln | grep 'LISTEN' | grep ":${c}" >/dev/null 2>&1 || [ "$c" = "53" ]; then
json_add_object ""
json_add_string type redirect
json_add_string target DNAT