aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-19 00:36:51 -0700
committerRosen Penev <rosenp@gmail.com>2021-06-19 14:10:20 -0700
commitcaa2cc5cc1478ab66af15adb1979e63caea2eb77 (patch)
treee13b39c7762cb5f70a35a03048aae6fc5949af79
parenta83dcc11fb8f6f82dc04512a1d106b5dc78b3078 (diff)
sumo: fix compilation when gtest is present
Removes cmake check for gtest. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/sumo/patches/010-gtest.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/utils/sumo/patches/010-gtest.patch b/utils/sumo/patches/010-gtest.patch
new file mode 100644
index 000000000..66a941c88
--- /dev/null
+++ b/utils/sumo/patches/010-gtest.patch
@@ -0,0 +1,10 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -339,7 +339,6 @@ if (SUMO_LIBRARIES AND WIN32)
+ file(GLOB TEXTTEST_EXECUTABLE "${SUMO_LIBRARIES}/TextTest-*/texttest.exe")
+ else ()
+ # for Linux and Mac only
+- find_package(GTest)
+ endif ()
+
+ find_package(XercesC REQUIRED)