aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-25 18:14:58 +0200
committerDaniel Golle <daniel@makrotopia.org>2024-02-25 18:24:12 +0000
commitca6afe964b248417488b22bf6da0663dce5ed09a (patch)
treef75da6462fdadc91ad45e0555ec14eea5bcdb323
parentdccb910ae0cb3d654a6432f7b82cd44d46db75e2 (diff)
inotify-tools: update to 4.23.9.0
- Workaround superfluous linking with libstdccp Signed-off-by: krant <aleksey.vasilenko@gmail.com>
-rw-r--r--utils/inotify-tools/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/utils/inotify-tools/Makefile b/utils/inotify-tools/Makefile
index a5d4203cf..6d537a828 100644
--- a/utils/inotify-tools/Makefile
+++ b/utils/inotify-tools/Makefile
@@ -1,9 +1,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=inotify-tools
-PKG_VERSION:=3.20.11.0
-PKG_HASH:=58a3cde89e4a5111a87ac16b56b06a8f885460fca0aea51b69c856ce30a37a14
-PKG_RELEASE:=2
+PKG_VERSION:=4.23.9.0
+PKG_HASH:=1dfa33f80b6797ce2f6c01f454fd486d30be4dca1b0c5c2ea9ba3c30a5c39855
+PKG_RELEASE:=1
PKG_SOURCE_URL:=https://codeload.github.com/rvoicilas/inotify-tools/tar.gz/$(PKG_VERSION)?
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -23,6 +23,9 @@ ifneq ($(CONFIG_USE_MUSL),)
TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
endif
+## Avoid linking with libstdcpp
+TARGET_CXXFLAGS+= -nodefaultlibs -lc -fno-exceptions
+
define Build/Prepare
$(call Build/Prepare/Default)
$(CP) $(PKG_BUILD_DIR)/README.md $(PKG_BUILD_DIR)/README