aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2020-10-27 09:21:16 +0100
committerGitHub <noreply@github.com>2020-10-27 09:21:16 +0100
commitca5dc9754f29d8a8a5d4da3731de97db84c1574e (patch)
tree56e0e3b308ec50c4bcedd570af20b436915fc2fe
parent62cd5a3d9a280a99af79fb37e52ddbec93ce05e2 (diff)
parent2bba943e99b4abfcaed1d7a12e3e287016d36f8e (diff)
Merge pull request #13752 from TDT-AG/pr/20201023-xinetd
xinetd: some changes
-rw-r--r--net/xinetd/Makefile3
-rw-r--r--net/xinetd/files/xinetd.init4
-rw-r--r--net/xinetd/files/xinetd.uci.conf.sample12
3 files changed, 13 insertions, 6 deletions
diff --git a/net/xinetd/Makefile b/net/xinetd/Makefile
index f38965317..84f915307 100644
--- a/net/xinetd/Makefile
+++ b/net/xinetd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=xinetd
PKG_VERSION:=2.3.15
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/xinetd-org/xinetd/archive
@@ -41,6 +41,7 @@ endef
define Package/xinetd/conffiles
/etc/config/xinetd
+/etc/xinetd.d
endef
TARGET_CFLAGS += -DNO_RPC
diff --git a/net/xinetd/files/xinetd.init b/net/xinetd/files/xinetd.init
index 188dcfcc6..207122381 100644
--- a/net/xinetd/files/xinetd.init
+++ b/net/xinetd/files/xinetd.init
@@ -12,6 +12,7 @@ PIDFILE="/var/run/xinetd.pid"
CONF_FILE="/etc/config/xinetd"
GENERATED_CONF_FILE="/var/run/xinetd.conf"
+OTHER_CONF_DIR="/tmp/xinetd.d"
ServiceEntry="false"
ListName=""
@@ -101,11 +102,14 @@ generate_config() {
echo "}" >> $GENERATED_CONF_FILE
echo "" >> $GENERATED_CONF_FILE
echo "includedir /etc/xinetd.d" >> $GENERATED_CONF_FILE
+ echo "includedir $OTHER_CONF_DIR" >> $GENERATED_CONF_FILE
config_load xinetd
}
start_service() {
+ mkdir -p $OTHER_CONF_DIR
+
generate_config
procd_open_instance
diff --git a/net/xinetd/files/xinetd.uci.conf.sample b/net/xinetd/files/xinetd.uci.conf.sample
index 4988a895d..13bce5373 100644
--- a/net/xinetd/files/xinetd.uci.conf.sample
+++ b/net/xinetd/files/xinetd.uci.conf.sample
@@ -2,10 +2,12 @@
# option type 'UNLISTED'
# option port '6556'
# option socket_type 'stream'
-# option protocol 'tcp'
-# option wait 'no'
+# option protocol 'tcp'
+# option wait 'no'
# option user 'root'
# option server '/usr/bin/check_mk_agent'
-# option log_on_success ''
-# option only_from '127.0.0.1'
-# option disable 'no'
+# list only_from '127.0.0.1'
+# list only_from '1.1.1.1'
+# list log_on_success 'PID'
+# list log_on_success 'HOST'
+# option disable 'no'