aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-02-08 20:45:00 -0800
committerRosen Penev <rosenp@gmail.com>2019-02-08 20:50:24 -0800
commitca3c43af1d00a3a4994d72c9153ac4b0eebd8430 (patch)
tree74df9c9c1a8abb9304af6a69464eb51ba16b7296
parentfb209cf568d93c5d164b85872f5abaf904ed4348 (diff)
keyutils: Make reproducible
Based on debian patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/keyutils/Makefile4
-rw-r--r--libs/keyutils/patches/010-reproducible-build.patch11
2 files changed, 13 insertions, 2 deletions
diff --git a/libs/keyutils/Makefile b/libs/keyutils/Makefile
index 648b288ac..430473cd4 100644
--- a/libs/keyutils/Makefile
+++ b/libs/keyutils/Makefile
@@ -1,4 +1,4 @@
-#
+#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=keyutils
PKG_VERSION:=1.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://people.redhat.com/dhowells/keyutils/
diff --git a/libs/keyutils/patches/010-reproducible-build.patch b/libs/keyutils/patches/010-reproducible-build.patch
new file mode 100644
index 000000000..3cf9b544c
--- /dev/null
+++ b/libs/keyutils/patches/010-reproducible-build.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -108,7 +108,7 @@ all: keyctl request-key key.dns_resolver
+ ###############################################################################
+ #RPATH = -Wl,-rpath,$(LIBDIR)
+
+-VCPPFLAGS := -DPKGBUILD="\"$(shell date -u +%F)\""
++VCPPFLAGS := -DPKGBUILD="\"for OpenWrt"\"
+ VCPPFLAGS += -DPKGVERSION="\"keyutils-$(VERSION)\""
+ VCPPFLAGS += -DAPIVERSION="\"libkeyutils-$(APIVERSION)\""
+