aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2019-12-03 22:34:25 +0100
committerMichael Heimpold <mhei@heimpold.de>2019-12-03 22:34:32 +0100
commitc9ce769b1aab4abbacaf54fd4074e1ab8fbfd93a (patch)
tree48b9d88499138f4b2bb5e9b5e277845b1c6f7bff
parent87b21390ba4f72ae6b70b75904bb352d7fe4fa03 (diff)
cyrus-sasl: install pkg-config file and fine-tune installed files
Installing the .pc files helps other programs to detect the presence of libsasl2. While at, reduce the glob pattern a little bit to not include unneeded symlinks. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
-rw-r--r--libs/cyrus-sasl/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/libs/cyrus-sasl/Makefile b/libs/cyrus-sasl/Makefile
index 2a670e9b6..a14b5030c 100644
--- a/libs/cyrus-sasl/Makefile
+++ b/libs/cyrus-sasl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cyrus-sasl
PKG_VERSION:=2.1.27
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
@@ -101,13 +101,15 @@ define Build/InstallDev
ln -sf libsasl2.so $(1)/usr/lib/libsasl.so
$(INSTALL_DIR) $(1)/usr/lib/sasl2
$(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.{a,so*} $(1)/usr/lib/sasl2/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libsasl2.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libsasl2/install
$(INSTALL_DIR) $(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsasl2.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsasl2.so.* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/sasl2
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.so* $(1)/usr/lib/sasl2/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.so.* $(1)/usr/lib/sasl2/
endef
$(eval $(call BuildPackage,libsasl2))