aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsbyx <steven@midlink.org>2014-09-04 18:21:38 +0200
committersbyx <steven@midlink.org>2014-09-04 18:21:38 +0200
commitc857e2d26c499134d781493b4b57876b10acf46f (patch)
tree42e86e28ce443c712e108af23d044d2e02864f76
parent72063428e66b32c0de225d5228a3e53d0de4c6f9 (diff)
parentca423611e84496566b71213c9c6c5032c1575bd5 (diff)
Merge pull request #277 from roger-/micropython
micropython: simplify makefile + update
-rw-r--r--lang/micropython/Makefile22
1 files changed, 3 insertions, 19 deletions
diff --git a/lang/micropython/Makefile b/lang/micropython/Makefile
index b318e3e2d..77a94ab26 100644
--- a/lang/micropython/Makefile
+++ b/lang/micropython/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=micropython
-PKG_VERSION=1.3.1-20140830-$(PKG_SOURCE_VERSION)
+PKG_VERSION=1.3.1-20140904-$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
@@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=LICENSE
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/micropython/micropython.git
-PKG_SOURCE_VERSION:=90fad65d2fb2695e1941296a6a55c175982299f2
+PKG_SOURCE_VERSION:=b534e1b9f14c189d2cef209d40f598e62164694a
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
@@ -39,25 +39,9 @@ define Package/micropython/description
that is optimised to run on a microcontroller (and low power computers).
endef
-# This is necessary for MIPS only (based on https://github.com/pfalcon/micropython/blob/cross/unix/build-mips.sh)
-MIPS_CFLAGS_EXTRA += -DMICROPY_GCREGS_SETJMP=1
-
-ifeq ($(ARCH),mips)
- TARGET_CFLAGS_EXTRA += $(MIPS_CFLAGS_EXTRA)
-endif
-
-ifeq ($(ARCH),mipsel)
- TARGET_CFLAGS_EXTRA += $(MIPS_CFLAGS_EXTRA)
-endif
-
-ifneq ($(ARCH),x86_64)
- TARGET_CFLAGS_EXTRA += -DMICROPY_EMIT_X64=0
-endif
-
MAKE_FLAGS += \
-C $(PKG_BUILD_DIR)/unix \
- MICROPY_USE_READLINE=0 \
- CFLAGS_EXTRA="$(TARGET_CFLAGS_EXTRA)"
+ MICROPY_USE_READLINE=0
define Package/micropython/install
$(INSTALL_DIR) $(1)/usr/bin