aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2017-01-19 15:33:07 -0500
committerTed Hess <thess@kitschensync.net>2017-01-19 15:34:13 -0500
commitc82573e64e27a58b3bffda336c51d3545cc88204 (patch)
treee149d454abe5f33ef8be51af472c23a4da002f9a
parent8dd6ca99fc55da37921a9ffb9d2802295a0055b8 (diff)
icecast: Fix configure if both vorbis and tremor host packages installed
Signed-off-by: Ted Hess <thess@kitschensync.net>
-rw-r--r--multimedia/icecast/Makefile6
-rw-r--r--multimedia/icecast/patches/001-icecast-2.4.0-tremor.patch2
2 files changed, 7 insertions, 1 deletions
diff --git a/multimedia/icecast/Makefile b/multimedia/icecast/Makefile
index 97c5bd7aa..2ef95b781 100644
--- a/multimedia/icecast/Makefile
+++ b/multimedia/icecast/Makefile
@@ -55,6 +55,12 @@ CONFIGURE_ARGS+= \
--with-xslt-config="$(STAGING_DIR)/usr/bin/xslt-config"
+# Manually edit configure in case both vorbis and tremor host packages are installed
+define Build/Configure
+ $(SED) 's,-lvorbis -lm,-lvorbisidec -logg ,g' $(PKG_BUILD_DIR)/configure
+ $(call Build/Configure/Default)
+endef
+
define Package/icecast/install
$(INSTALL_DIR) $(1)/etc
$(CP) $(PKG_INSTALL_DIR)/etc/icecast.xml $(1)/etc/
diff --git a/multimedia/icecast/patches/001-icecast-2.4.0-tremor.patch b/multimedia/icecast/patches/001-icecast-2.4.0-tremor.patch
index 7fd9d52ba..49861d2e3 100644
--- a/multimedia/icecast/patches/001-icecast-2.4.0-tremor.patch
+++ b/multimedia/icecast/patches/001-icecast-2.4.0-tremor.patch
@@ -21,7 +21,7 @@
return NULL;
}
-+/* Some additional functions from vorbis missing from tremore */
++/* Some additional functions from vorbis missing from tremor */
+
+static void _v_writestring(oggpack_buffer *o,char *s, int bytes)
+{