aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-10 13:07:45 -0700
committerRosen Penev <rosenp@gmail.com>2020-08-10 15:30:53 -0700
commitc67d5716bdd641bf67334877d9bbde66b818eaa2 (patch)
tree9cdd059f3e7de40d40f07f381befeed455a11e33
parent11c4323665df0e4d03ce2d843f0a52401f0e0a8e (diff)
quota: fix compilation without sys/cdefs
sys/cdefs.h does not come included with musl. It's also deprecated. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/quota/Makefile2
-rw-r--r--utils/quota/patches/010-cdefs.patch18
2 files changed, 19 insertions, 1 deletions
diff --git a/utils/quota/Makefile b/utils/quota/Makefile
index 9633a79b8..49af89eb1 100644
--- a/utils/quota/Makefile
+++ b/utils/quota/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=quota
PKG_VERSION:=4.05
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/linuxquota
diff --git a/utils/quota/patches/010-cdefs.patch b/utils/quota/patches/010-cdefs.patch
new file mode 100644
index 000000000..a44978e7e
--- /dev/null
+++ b/utils/quota/patches/010-cdefs.patch
@@ -0,0 +1,18 @@
+--- a/quota.h
++++ b/quota.h
+@@ -1,7 +1,6 @@
+ #ifndef GUARD_QUOTA_H
+ #define GUARD_QUOTA_H
+
+-#include <sys/cdefs.h>
+ #include <sys/types.h>
+ #include <stdint.h>
+
+@@ -182,6 +181,6 @@ enum {
+ #endif
+ #endif
+
+-long quotactl __P((int, const char *, qid_t, caddr_t));
++long quotactl (int, const char *, qid_t, caddr_t);
+
+ #endif /* _QUOTA_ */