aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Vasilek <michal.vasilek@nic.cz>2022-11-21 13:49:20 +0100
committerTianling Shen <cnsztl@gmail.com>2022-11-22 00:59:12 +0800
commitc2ad338b0f0fb5df4c84770fa6408f18bd347671 (patch)
tree416df836cfb8ef3dcb57ae3d36c76f60c46d1072
parent88a1535d00e1047041cb9328a6f6eac310af1714 (diff)
librespeed-cli: rename binary to librespeed-cli
upstream names the binary librespeed-cli and this avoids a conflict with python3-speedtest-cli Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
-rw-r--r--utils/librespeed-cli/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/utils/librespeed-cli/Makefile b/utils/librespeed-cli/Makefile
index b724b8754..a816fdaec 100644
--- a/utils/librespeed-cli/Makefile
+++ b/utils/librespeed-cli/Makefile
@@ -41,5 +41,11 @@ define Package/librespeed-cli/description
LibreSpeed client for measuring internet speed from command line.
endef
+define Package/librespeed-cli/install
+ $(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/speedtest-cli $(1)/usr/bin/librespeed-cli
+endef
+
$(eval $(call GoBinPackage,librespeed-cli))
$(eval $(call BuildPackage,librespeed-cli))