aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-07-28 02:28:13 +0800
committerTianling Shen <cnsztl@gmail.com>2023-08-04 01:53:32 +0800
commitc2a725ec0029c78eb24eb5784bb99e6f7f69ffe7 (patch)
tree8470269ea9ba13524d7dac76660a38d3b62e542d
parent360427948ee6b65856524e3ce911318be9f29c3b (diff)
python-docutils: Update to 0.20.1
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python-docutils/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/lang/python/python-docutils/Makefile b/lang/python/python-docutils/Makefile
index 50875051f..bd85be0a2 100644
--- a/lang/python/python-docutils/Makefile
+++ b/lang/python/python-docutils/Makefile
@@ -1,14 +1,15 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=docutils
-PKG_VERSION:=0.19
-PKG_RELEASE:=2
+PKG_NAME:=python-docutils
+PKG_VERSION:=0.20.1
+PKG_RELEASE:=1
-PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=33995a6753c30b7f577febfc2c50411fec6aac7f7ffeb7c4cfe5991072dcf9e6
+PYPI_NAME:=docutils
+PKG_HASH:=f08a4e276c3a1583a86dce3e34aba3fe04d02bba2dd51ed16106244e8a923e3b
PKG_MAINTAINER:=Daniel Danzberger <daniel@dd-wrt.com>
-PKG_LICENSE:=MIT
+PKG_LICENSE:=Public-Domain BSD-2-License Python-2.0.1 GPL-3.0-or-later
+PKG_LICENSE_FILES:=COPYING.txt licenses/BSD-2-Clause.txt licenses/python-2-1-1.txt licenses/gpl-3-0.txt
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
@@ -18,15 +19,16 @@ define Package/python3-docutils
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
- TITLE:=docutils
- URL:=http://docutils.sourceforge.net
+ TITLE:=Documentation Utilities
+ URL:=https://docutils.sourceforge.io/
DEPENDS:=+python3
endef
define Package/python3-docutils/description
-Docutils is a modular system for processing documentation into useful formats,
-such as HTML, XML, and LaTeX. For input Docutils supports reStructuredText,
-an easy-to-read, what-you-see-is-what-you-get plaintext markup syntax.
+Docutils is a modular system for processing documentation into useful
+formats, such as HTML, XML, and LaTeX. For input Docutils supports
+reStructuredText, an easy-to-read, what-you-see-is-what-you-get
+plaintext markup syntax.
endef
$(eval $(call Py3Package,python3-docutils))