aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2020-06-03 16:58:34 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2020-06-21 13:25:45 +0300
commitc26eca5491f772686bd34bcc05aef649b20c77cd (patch)
tree78893d63e3b74e32733d481fea9fda2042635ec5
parentf2639763768f7981ae7971697e0b7dce1100b557 (diff)
numpy: add new package
Essentially, this is a re-spin from https://github.com/openwrt/packages/pull/9797/ But a really trimmed down version. Only the Py3 variant is added now, which makes the Makefile really small now. Cython is needed on the host, to cythonize some files. The package needs targets with hard-float enabled. This is because on some soft-float targets floating-point exception constants aren't defined. We can define some dummy values, but that ends up being a bit too much work. So, for that, the package depends on HAS_FPU or KERNEL_MIPS_FPU_EMULATOR. This way, numpy should be buildable on hard-float, or for MIPS on the FPU emulator being compiled in. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
-rw-r--r--lang/python/numpy/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/lang/python/numpy/Makefile b/lang/python/numpy/Makefile
new file mode 100644
index 000000000..9bbf1fb5b
--- /dev/null
+++ b/lang/python/numpy/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2019 Jakub Piotr Cłapa <jpc@loee.pl>
+# Copyright (C) 2020 Alexandru Ardelean <ardeleanalex@gmail.com>
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=numpy
+PKG_VERSION:=1.18.5
+PKG_RELEASE:=1
+
+PYPI_NAME:=$(PKG_NAME)
+PKG_HASH:=34e96e9dae65c4839bd80012023aadd6ee2ccb73ce7fdf3074c62f301e63120b
+
+PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE.txt
+PKG_CPE_ID:=cpe:/a:numpy:numpy
+
+# yes, zip... sigh
+PYPI_SOURCE_EXT:=zip
+HOST_PYTHON3_PACKAGE_BUILD_DEPENDS="Cython==0.29.19"
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-numpy
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=The fundamental package for scientific computing with Python
+ URL:=https://www.numpy.org/
+ DEPENDS:=@!SOFT_FLOAT +INSTALL_GFORTRAN:libgfortran +python3
+endef
+
+define Package/python3-numpy/description
+NumPy is the fundamental package for array computing with Python.
+
+By default, this package is built without some modules.
+For some modules to be available, the INSTALL_GFORTRAN symbol needs
+to be enabled in the OpenWrt core/toolchain.
+endef
+
+$(eval $(call Py3Package,python3-numpy))
+$(eval $(call BuildPackage,python3-numpy))
+$(eval $(call BuildPackage,python3-numpy-src))