aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-02-20 18:13:33 -0800
committerRosen Penev <rosenp@gmail.com>2021-02-20 20:03:55 -0800
commitbf1a138f9276718a76589b3b170648d85bbb8c0b (patch)
treea3a5217f5a0c5ae6b3302f3cdcf7816f3b85e151
parentb945b0790f8ababf8c36b9327d8d37f2ff90675b (diff)
sane-backends: remove outdated C++ patch
std::round was unavailable because of a wrong configure var from the uClibc days. Fixed upstream with 1647790ae6202bd70b199e2aa44f8eb43e8d3af1 Refreshed patches with make package/sane-backends/refresh Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/sane-backends/Makefile2
-rw-r--r--utils/sane-backends/patches/101-fix_uclibc_std_rand.patch16
2 files changed, 1 insertions, 17 deletions
diff --git a/utils/sane-backends/Makefile b/utils/sane-backends/Makefile
index db607171f..ab53eff9e 100644
--- a/utils/sane-backends/Makefile
+++ b/utils/sane-backends/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sane-backends
PKG_VERSION:=1.0.31
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/8bf1cae2e1803aefab9e5331550e5d5d/
diff --git a/utils/sane-backends/patches/101-fix_uclibc_std_rand.patch b/utils/sane-backends/patches/101-fix_uclibc_std_rand.patch
deleted file mode 100644
index 5478a3865..000000000
--- a/utils/sane-backends/patches/101-fix_uclibc_std_rand.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-https://gitlab.com/sane-project/backends/issues/237
-
---- a/backend/genesys/image_pipeline.cpp
-+++ b/backend/genesys/image_pipeline.cpp
-@@ -754,7 +754,11 @@ bool ImagePipelineNodeCalibrate::get_nex
-
- float value_f = static_cast<float>(value) / max_value;
- value_f = (value_f - offset_[curr_calib_i]) * multiplier_[curr_calib_i];
-+#if defined(__UCLIBC__)
-+ value_f = round(value_f * max_value);
-+#else
- value_f = std::round(value_f * max_value);
-+#endif
- value = clamp<std::int32_t>(static_cast<std::int32_t>(value_f), 0, max_value);
- set_raw_channel_to_row(out_data, x, ch, value, format);
-