aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2014-06-13 16:43:11 +0200
committerDaniel Golle <daniel@makrotopia.org>2014-06-13 16:45:23 +0200
commitbea53b612f8dda6930063de4e728c9b625057eca (patch)
treec1dde71bb8dc73b26e83a4b4599141b09db7e6a2
parent6c6bbe89d1ab16ea3dfa8b093da72e92c6f2fdf5 (diff)
Add mktorrent package
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
1 files changed, 39 insertions, 0 deletions
diff --git a/utils/mktorrent/Makefile b/utils/mktorrent/Makefile
new file mode 100644
index 000000000..3ff981377
--- /dev/null
+++ b/utils/mktorrent/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mktorrent
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.sourceforge.net/$(PKG_NAME)/
+PKG_MD5SUM:=0da00209da96a0dc39efbb6eb5b4d8ff
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/mktorrent
+ SUBMENU:=BitTorrent
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=mktorrent
+ URL:=http://mktorrent.sourceforge.net/
+endef
+
+define Package/mktorrent/Description
+ mktorrent is a simple command line utility to create BitTorrent metainfo files.
+endef
+
+
+define Package/mktorrent/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/mktorrent $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,mktorrent))