aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-01-30 23:19:58 -0800
committerRosen Penev <rosenp@gmail.com>2022-02-14 17:20:22 -0800
commitbde86a6cba7ea2c9f01f13a9fdd0a9b7d1b4512e (patch)
tree0d904d34449e62add52bc7d3c6a02c1927a80356
parent1cb6f062004fcd1b278ed946f6f535ded52d1836 (diff)
mktorrent: fix bad format for 64bit platforms
The Makefile tries and fails to run a binary that sets it properly. Just hardcode it. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/mktorrent/Makefile2
-rw-r--r--utils/mktorrent/patches/010-format.patch20
2 files changed, 21 insertions, 1 deletions
diff --git a/utils/mktorrent/Makefile b/utils/mktorrent/Makefile
index 3bc241a61..4afbba4b7 100644
--- a/utils/mktorrent/Makefile
+++ b/utils/mktorrent/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mktorrent
PKG_VERSION:=1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/utils/mktorrent/patches/010-format.patch b/utils/mktorrent/patches/010-format.patch
new file mode 100644
index 000000000..e7f62b04f
--- /dev/null
+++ b/utils/mktorrent/patches/010-format.patch
@@ -0,0 +1,20 @@
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -61,6 +61,6 @@ OBJS = $(SRCS:.c=.o)
+ all: $(program)
+
+ %.o: %.c $(HEADERS) prefix
+- $(CC) $(CFLAGS) $(DEFINES) -DPRIoff="\"$(OFFPRFX)d\"" -DVERSION="\"$(version)\"" -c $<
++ $(CC) $(CFLAGS) $(DEFINES) -DPRIoff="PRId64 \"d\"" -DVERSION="\"$(version)\"" -c $<
+
+ include rules.mk
+--- a/init.c
++++ b/init.c
+@@ -25,6 +25,7 @@ Foundation, Inc., 51 Franklin Street, Fi
+ #include <sys/stat.h> /* the stat structure */
+ #include <unistd.h> /* getopt(), getcwd(), sysconf() */
+ #include <string.h> /* strcmp(), strlen(), strncpy() */
++#include <inttypes.h>
+ #ifdef USE_LONG_OPTIONS
+ #include <getopt.h> /* getopt_long() */
+ #endif