aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Woodhouse <dwmw2@infradead.org>2020-06-11 09:27:31 +0100
committerDavid Woodhouse <dwmw2@infradead.org>2020-06-11 09:27:31 +0100
commitbcaf610a29269b52f51d15cfe0a656eefa87c683 (patch)
treed2c9ee205e696f485427b93a3558dee3780c707c
parentf10f1b6c4056bf5714f85456683436de0b2cf36a (diff)
minizip: fix $(PKG_SOURCE) to include $(PKG_NAME) to avoid conflicts
Just as Rosen did for cereal in #12477. Likewise, clean up the CMAKE_OPTIONS onto separate lines for readability. Signed-off-by: David Woodhouse <dwmw2@infradead.org>
-rw-r--r--libs/minizip/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/libs/minizip/Makefile b/libs/minizip/Makefile
index 58e6d3865..431e0cb13 100644
--- a/libs/minizip/Makefile
+++ b/libs/minizip/Makefile
@@ -8,10 +8,10 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=minizip
PKG_VERSION:=2.9.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
-PKG_SOURCE:=$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/nmoinvaz/minizip/archive/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/nmoinvaz/minizip/tar.gz/$(PKG_VERSION)?
PKG_HASH:=f64b2d228a03673a8ec36a53402e2108437226fd9170d49b7f0c0bca94708b93
PKG_MAINTAINER:=David Woodhouse <dwmw2@infradead.org>
@@ -20,11 +20,16 @@ PKG_LICENSE_FILES:=LICENSE
PKG_BUILD_PARALLEL:=1
-CMAKE_OPTIONS:=-DINSTALL_INC_DIR=/usr/include/minizip -DMZ_BZIP2=OFF -DBUILD_SHARED_LIBS=ON -DMZ_LIBBSD=OFF
-
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
+CMAKE_OPTIONS += \
+ -DINSTALL_INC_DIR=/usr/include/minizip \
+ -DBUILD_SHARED_LIBS=ON \
+ -DMZ_BZIP2=OFF \
+ -DMZ_LIBBSD=OFF
+
+
define Package/minizip
TITLE:=Fork of the popular zip manipulation library found in the zlib distribution
SECTION:=libs