aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-06-29 18:00:44 +0200
committerJo-Philipp Wich <jow@openwrt.org>2015-06-29 18:00:44 +0200
commitbc4d049918ec7507e08bfa473cbc27383b581ebf (patch)
tree0175dc9b18444d31932c12c847f9af0c8947e910
parent5885ddf5a713ff222f78616610d617db95154681 (diff)
libnet-1.2.x: fix uClibc regression caused by #1410
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
-rw-r--r--libs/libnet-1.2.x/Makefile2
-rw-r--r--libs/libnet-1.2.x/patches/100-musl-compat.patch11
2 files changed, 9 insertions, 4 deletions
diff --git a/libs/libnet-1.2.x/Makefile b/libs/libnet-1.2.x/Makefile
index a9d7e7508..a79116337 100644
--- a/libs/libnet-1.2.x/Makefile
+++ b/libs/libnet-1.2.x/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libnet
PKG_VERSION:=1.2-rc3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://sourceforge.net/projects/libnet-dev/files/
diff --git a/libs/libnet-1.2.x/patches/100-musl-compat.patch b/libs/libnet-1.2.x/patches/100-musl-compat.patch
index fcb4188a0..b95366a07 100644
--- a/libs/libnet-1.2.x/patches/100-musl-compat.patch
+++ b/libs/libnet-1.2.x/patches/100-musl-compat.patch
@@ -1,11 +1,16 @@
--- a/src/libnet_link_linux.c
+++ b/src/libnet_link_linux.c
-@@ -30,7 +30,7 @@
+@@ -30,13 +30,8 @@
#include <sys/time.h>
#include <net/if.h>
-#if (__GLIBC__)
-+#if (!__UCLIBC__)
#include <netinet/if_ether.h>
#include <net/if_arp.h>
- #else
+-#else
+-#include <linux/if_arp.h>
+-#include <linux/if_ether.h>
+-#endif
+
+ #if (HAVE_PACKET_SOCKET)
+ #ifndef SOL_PACKET