aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-04-01 08:24:42 +0200
committerJohn Crispin <john@phrozen.org>2016-04-01 08:24:42 +0200
commitbbbef2847b4f0ad395f995c4d4f90d028903b72e (patch)
treeba57169b93a0e2be2102575a5bf926cb60dded4d
parent5d4caa73f10d665432b834fe77c843953142ba50 (diff)
parentbca789b6bb432b55b076af4d7045a0d1a508f11c (diff)
Merge pull request #2569 from nxhack/node-npm-cache
node-* : specify npm_config_cache directory
-rw-r--r--lang/node-arduino-firmata/Makefile1
-rw-r--r--lang/node-cylon/Makefile1
-rw-r--r--lang/node-hid/Makefile1
-rw-r--r--lang/node-serialport/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/lang/node-arduino-firmata/Makefile b/lang/node-arduino-firmata/Makefile
index b88b2c43e..a21b23348 100644
--- a/lang/node-arduino-firmata/Makefile
+++ b/lang/node-arduino-firmata/Makefile
@@ -52,6 +52,7 @@ define Build/Compile
$(MAKE_FLAGS) \
npm_config_arch=$(CONFIG_ARCH) \
npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
+ npm_config_cache=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/npm-cache \
PREFIX="$(PKG_INSTALL_DIR)/usr/" \
$(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
endef
diff --git a/lang/node-cylon/Makefile b/lang/node-cylon/Makefile
index 9d9b827a1..25341d3bb 100644
--- a/lang/node-cylon/Makefile
+++ b/lang/node-cylon/Makefile
@@ -67,6 +67,7 @@ define Build/Compile
$(MAKE_FLAGS) \
npm_config_arch=$(CONFIG_ARCH) \
npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
+ npm_config_cache=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/npm-cache \
PREFIX="$(PKG_INSTALL_DIR)/usr/" \
$(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
endef
diff --git a/lang/node-hid/Makefile b/lang/node-hid/Makefile
index c40901bdc..3a929fb14 100644
--- a/lang/node-hid/Makefile
+++ b/lang/node-hid/Makefile
@@ -49,6 +49,7 @@ define Build/Compile
$(MAKE_FLAGS) \
npm_config_arch=$(CONFIG_ARCH) \
npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
+ npm_config_cache=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/npm-cache \
PREFIX="$(PKG_INSTALL_DIR)/usr/" \
$(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
endef
diff --git a/lang/node-serialport/Makefile b/lang/node-serialport/Makefile
index c414628e3..90a9fd7aa 100644
--- a/lang/node-serialport/Makefile
+++ b/lang/node-serialport/Makefile
@@ -49,6 +49,7 @@ define Build/Compile
$(MAKE_FLAGS) \
npm_config_arch=$(CONFIG_ARCH) \
npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
+ npm_config_cache=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/npm-cache \
PREFIX="$(PKG_INSTALL_DIR)/usr/" \
$(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
endef