aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-23 15:37:53 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-23 15:37:53 -0300
commitbb31b90d73ae5a42b4c1b3fd6084c1896631b21c (patch)
tree0d45215b46820421be45a913d3e66d8374bed723
parentd9e9b59159309449df7a7a6d4ab87980dc16eac2 (diff)
libshout: add openssl 1.1.0 compatibility
Avoid calling deprecated and unnecessary library initialization functions with openssl >= 1.1.0. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
-rw-r--r--libs/libshout/Makefile2
-rw-r--r--libs/libshout/patches/150-openssl-1.1.patch15
2 files changed, 16 insertions, 1 deletions
diff --git a/libs/libshout/Makefile b/libs/libshout/Makefile
index 6a02ff698..83d527485 100644
--- a/libs/libshout/Makefile
+++ b/libs/libshout/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libshout
PKG_VERSION:=2.4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/libs/libshout/patches/150-openssl-1.1.patch b/libs/libshout/patches/150-openssl-1.1.patch
new file mode 100644
index 000000000..77ee83294
--- /dev/null
+++ b/libs/libshout/patches/150-openssl-1.1.patch
@@ -0,0 +1,15 @@
+--- a/src/tls.c
++++ b/src/tls.c
+@@ -63,10 +63,12 @@ static inline int tls_setup(shout_tls_t
+ {
+ SSL_METHOD *meth;
+
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ SSL_library_init();
+ SSL_load_error_strings();
+ SSLeay_add_all_algorithms();
+ SSLeay_add_ssl_algorithms();
++#endif
+
+ meth = TLSv1_client_method();
+ if (!meth)