aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-29 10:11:05 +0800
committerTianling Shen <cnsztl@gmail.com>2023-10-02 19:14:01 +0800
commitbb278a015c6b76ca2c9fdf6663dbd7428777915e (patch)
tree483806c99ecbdfe782e6942c53b536136f5af1d1
parentb788f77db48d6d20f925daa762a70fe5c40dc54a (diff)
python-pyopenssl: Update to 23.2.0
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python-pyopenssl/Makefile10
-rw-r--r--lang/python/python-pyopenssl/test.sh5
2 files changed, 10 insertions, 5 deletions
diff --git a/lang/python/python-pyopenssl/Makefile b/lang/python/python-pyopenssl/Makefile
index 686ce91a9..383d48d6b 100644
--- a/lang/python/python-pyopenssl/Makefile
+++ b/lang/python/python-pyopenssl/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015-2018 OpenWrt.org
+# Copyright (C) 2015-2016, 2018-2021, 2023 Jeffery To
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-pyopenssl
-PKG_VERSION:=21.0.0
+PKG_VERSION:=23.2.0
PKG_RELEASE:=1
PYPI_NAME:=pyOpenSSL
-PKG_HASH:=5e2d8c5e46d0d865ae933bef5230090bdaf5506281e9eec60fa250ee80600cb3
+PKG_HASH:=276f931f55a452e7dea69c7173e984eb2a4407ce413c918aa34b55f82f9b8bac
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
@@ -31,8 +31,8 @@ define Package/python3-pyopenssl
URL:=https://pyopenssl.org/
DEPENDS:= \
+python3-light \
- +python3-cryptography \
- +python3-six
+ +python3-openssl \
+ +python3-cryptography
endef
define Package/python3-pyopenssl/description
diff --git a/lang/python/python-pyopenssl/test.sh b/lang/python/python-pyopenssl/test.sh
new file mode 100644
index 000000000..141dedd4d
--- /dev/null
+++ b/lang/python/python-pyopenssl/test.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+[ "$1" = python3-pyopenssl ] || exit 0
+
+python3 -m OpenSSL.debug