aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-04-18 17:22:21 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-06-05 17:18:51 -0700
commitbb1c950c5258caa1faab14c825608b553ed3fd2c (patch)
tree5005120921b4c402d20c3f873df10669175ef89c
parent20891e8d4236ae39d42e09debc211e1bb317f9a8 (diff)
tgt: Pass down TARGET_CPPFLAGS and TARGET_LDFLAGS
Make sure we pass down TARGET_CPPFLAGS and TARGET_LDFLAGS to fix build with external toolchains that don't automatically search for headers and libraries in $(STAGING_DIR). Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
-rw-r--r--net/tgt/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/tgt/Makefile b/net/tgt/Makefile
index c876179d0..82d11030f 100644
--- a/net/tgt/Makefile
+++ b/net/tgt/Makefile
@@ -41,9 +41,11 @@ Note that if you are interested in only iSCSI (probably you are), you need only
endef
define Build/Compile
- CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+ $(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
LD="$(TARGET_CC)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
install-programs
endef