aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatija Amidzic <matija.amidzic@sartura.hr>2018-06-26 12:44:30 +0200
committerMatija Amidzic <matija.amidzic@sartura.hr>2018-07-02 13:37:32 +0200
commitba647c04b53f0f7715cb2f8fd79f09a04ab05995 (patch)
treef06a85e9aebfa4a08178ab829c4e605d07e220bd
parent1a910ebd5e63057c1b7918974d33d9dffeb7139c (diff)
netopeer2: update to 0.5.26
Signed-off-by: Matija Amidzic <matija.amidzic@sartura.hr>
-rw-r--r--net/netopeer2/Makefile8
-rw-r--r--net/netopeer2/files/netopeer2-server.default10
-rw-r--r--net/netopeer2/patches/001-fix-for-cmake-build (renamed from net/netopeer2/patches/002-fix-for-cmake-build)16
-rw-r--r--net/netopeer2/patches/001-remove-sysrepoctl-commands-from-cmake40
4 files changed, 31 insertions, 43 deletions
diff --git a/net/netopeer2/Makefile b/net/netopeer2/Makefile
index b9f296866..09668f0f2 100644
--- a/net/netopeer2/Makefile
+++ b/net/netopeer2/Makefile
@@ -14,11 +14,11 @@ PKG_NAME:=netopeer2
PKG_LICENSE:=BSD-3-Clause
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
-PKG_VERSION:=0.4.13
+PKG_VERSION:=0.5.26
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=ae560bef2e70d274f6d028b59e3cb398ea2a621d
-PKG_MIRROR_HASH:=43b7f9c436afc76de539a7426b1462249326318b9b836f1d49282106a730a6b8
+PKG_SOURCE_VERSION:=3b99e99c9d507ddc89d21d7f1cbded494e6aa72e
+PKG_MIRROR_HASH:=d29b501d56bf9a2480759cc55368c842f69b07722afb3a0a70f05d6088f72574
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/CESNET/Netopeer2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION)
@@ -86,6 +86,8 @@ define Package/netopeer2-server/install
$(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/iana-crypt-hash.yang $(1)/etc/sysrepo/yang/iana-crypt-hash@2014-08-06.yang
$(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/ietf-x509-cert-to-name.yang $(1)/etc/sysrepo/yang/ietf-x509-cert-to-name@2014-12-10.yang
$(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/ietf-netconf-server.yang $(1)/etc/sysrepo/yang/ietf-netconf-server@2016-11-02.yang
+ $(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/ietf-netconf-monitoring.yang $(1)/etc/sysrepo/yang/ietf-netconf-monitoring@2010-10-04.yang
+ $(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/ietf-netconf-with-defaults.yang $(1)/etc/sysrepo/yang/ietf-netconf-with-defaults@2011-06-01.yang
$(INSTALL_DATA) $(PKG_BUILD_ROOT)/modules/ietf-system.yang $(1)/etc/sysrepo/yang/ietf-system@2014-08-06.yang
$(INSTALL_DIR) $(1)/etc/uci-defaults
diff --git a/net/netopeer2/files/netopeer2-server.default b/net/netopeer2/files/netopeer2-server.default
index 8a7b7fe7e..a93127036 100644
--- a/net/netopeer2/files/netopeer2-server.default
+++ b/net/netopeer2/files/netopeer2-server.default
@@ -34,6 +34,16 @@ if [ -x /bin/sysrepoctl ]; then
fi
fi
+ match=$(sysrepoctl -l | grep "ietf-netconf-monitoring ")
+ if [ ! "$match" ]; then
+ sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-monitoring@2010-10-04.yang -o root:root -p 600
+ fi
+
+ match=$(sysrepoctl -l | grep "ietf-netconf-with-defaults ")
+ if [ ! "$match" ]; then
+ sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-with-defaults@2011-06-01.yang -o root:root -p 600
+ fi
+
match=$(sysrepoctl -l | grep "ietf-system ")
if [ ! "$match" ]; then
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-system@2014-08-06.yang -o root:root -p 600
diff --git a/net/netopeer2/patches/002-fix-for-cmake-build b/net/netopeer2/patches/001-fix-for-cmake-build
index bd29d4d7d..920086a7c 100644
--- a/net/netopeer2/patches/002-fix-for-cmake-build
+++ b/net/netopeer2/patches/001-fix-for-cmake-build
@@ -43,6 +43,15 @@ Index: netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/keystored/CMake
project(keystored C)
include(GNUInstallDirs)
+@@ -140,7 +140,7 @@ if (SSH_KEY_INSTALL)
+ execute_process(COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/scripts/ssh-key-import.sh)")
+ endif()
+
+-add_custom_target(install-scripts-ide
++add_custom_target(install-scripts-ide-keystored
+ scripts/model-install.sh
+ scripts/ssh-key-import.sh
+ )
Index: netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/server/CMakeLists.txt
===================================================================
--- netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d.orig/server/CMakeLists.txt
@@ -56,3 +65,10 @@ Index: netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/server/CMakeLis
project(netopeer2-server C)
include(GNUInstallDirs)
+@@ -176,7 +176,7 @@ if (ENABLE_CONFIGURATION)
+ execute_process(COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/scripts/model-install.sh)")
+ endif()
+
+-add_custom_target(install-scripts-ide
++add_custom_target(install-scripts-ide-server
+ scripts/model-install.sh
diff --git a/net/netopeer2/patches/001-remove-sysrepoctl-commands-from-cmake b/net/netopeer2/patches/001-remove-sysrepoctl-commands-from-cmake
deleted file mode 100644
index 1d14ee0bf..000000000
--- a/net/netopeer2/patches/001-remove-sysrepoctl-commands-from-cmake
+++ /dev/null
@@ -1,40 +0,0 @@
-Index: netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/keystored/CMakeLists.txt
-===================================================================
---- netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee.orig/keystored/CMakeLists.txt
-+++ netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/keystored/CMakeLists.txt
-@@ -105,6 +105,7 @@ endif()
- install(DIRECTORY DESTINATION ${KEYSTORED_KEYS_DIR}
- DIRECTORY_PERMISSIONS OWNER_WRITE OWNER_READ OWNER_EXECUTE)
-
-+if(FALSE)
- # install all the required modules and enable features
- install(CODE "
- execute_process(COMMAND ${SYSREPOCTL_EXECUTABLE} -l RESULT_VARIABLE RET OUTPUT_VARIABLE INSTALLED_MODULES ERROR_VARIABLE OUT)
-@@ -154,6 +155,7 @@ install(CODE "
- message(FATAL_ERROR \" Command sysrepocfg import failed:\\n \${OUT}\")
- endif()
- endif()")
-+endif()
-
- # plugins should be installed into sysrepo plugins dir
- install(TARGETS keystored DESTINATION ${SR_PLUGINS_DIR})
-Index: netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/server/CMakeLists.txt
-===================================================================
---- netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee.orig/server/CMakeLists.txt
-+++ netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/server/CMakeLists.txt
-@@ -147,6 +147,7 @@ include_directories(${SYSREPO_INCLUDE_DI
- # install binary
- install(TARGETS netopeer2-server DESTINATION ${CMAKE_INSTALL_BINDIR})
-
-+if(FALSE)
- # only for configuration
- if (ENABLE_CONFIGURATION)
- # find sysrepoctl
-@@ -239,6 +240,7 @@ if (ENABLE_CONFIGURATION)
-
- endif()")
- endif()
-+endif()
-
- # clean cmake cache
- add_custom_target(cleancache