aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-15 21:55:17 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-19 01:56:23 +0800
commitba127c155a104be0a93c6f85877db0d6f27ba9df (patch)
tree48eb110fe751ca6fe87b0c99eba165551e7cc50b
parentc9b260f5ae9aee3de15f704ee454acfdef4c7579 (diff)
python3: Minor edits for python3-package.mk
* Remove PYTHON3_BIN_DIR, it isn't used anywhere in the repo * Rephrase *-src package description * Reduce Py3Package/$(1)/install indentation Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python3-package.mk17
1 files changed, 8 insertions, 9 deletions
diff --git a/lang/python/python3-package.mk b/lang/python/python3-package.mk
index b8ab01348..fe0df5a11 100644
--- a/lang/python/python3-package.mk
+++ b/lang/python/python3-package.mk
@@ -5,13 +5,12 @@
# See /LICENSE for more information.
#
-# Note: include this after `include $(TOPDIR)/rules.mk in your package Makefile
+# Note: include this file after `include $(TOPDIR)/rules.mk in your package Makefile
python3_mk_path:=$(dir $(lastword $(MAKEFILE_LIST)))
include $(python3_mk_path)python3-host.mk
PYTHON3_DIR:=$(STAGING_DIR)/usr
-PYTHON3_BIN_DIR:=$(PYTHON3_DIR)/bin
PYTHON3_INC_DIR:=$(PYTHON3_DIR)/include/python$(PYTHON3_VERSION)
PYTHON3_LIB_DIR:=$(PYTHON3_DIR)/lib/python$(PYTHON3_VERSION)
@@ -135,7 +134,6 @@ define Py3Package/ProcessFilespec
endef
define Py3Package
-
define Package/$(1)-src
$(call Package/$(1))
DEPENDS:=
@@ -148,8 +146,9 @@ define Py3Package
endef
define Package/$(1)-src/description
- $(call Package/$(1)/description).
- (Contains the Python3 sources for this package).
+ $$(call Package/$(1)/description)
+
+ This package contains the Python source files for $(1).
endef
define Package/$(1)-src/config
@@ -163,10 +162,10 @@ define Py3Package
ifndef Py3Package/$(1)/install
define Py3Package/$(1)/install
- if [ -d $(PKG_INSTALL_DIR)/usr/bin ]; then \
- $(INSTALL_DIR) $$(1)/usr/bin ; \
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $$(1)/usr/bin/ ; \
- fi
+ if [ -d $(PKG_INSTALL_DIR)/usr/bin ]; then \
+ $(INSTALL_DIR) $$(1)/usr/bin ; \
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $$(1)/usr/bin/ ; \
+ fi
endef
endif