aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2018-11-27 16:46:12 +0000
committerKarl Palsson <karlp@etactica.com>2018-11-28 10:15:04 +0000
commitb945bdf3c83ed25b69235128536dae52fc9afffa (patch)
treea119d4100ab6788c419f3736e71b5e8a6b151676
parentef207bd59730e2dd842bdc7661b249859695bbc9 (diff)
net/mosquitto: support more acl plugin options
Adds support for acl_plugin, and acl_opt_* options. acl_opt_* requires some care as it relies on the internal behaviour of cfg_load setting environment variables in a certain form. However, given that _all_ of the cfg_load infrastructure relies on that, we can be pretty sure that it won't change in a way that will hurt us. Originally reported as: https://github.com/openwrt/packages/pull/7434 Signed-off-by: Karl Palsson <karlp@etactica.com>
-rw-r--r--net/mosquitto/Makefile2
-rwxr-xr-xnet/mosquitto/files/etc/init.d/mosquitto5
2 files changed, 6 insertions, 1 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 37daddc41..515be4737 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mosquitto
PKG_VERSION:=1.5.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.txt
PKG_CPE_ID:=cpe:/a:eclipse:mosquitto
diff --git a/net/mosquitto/files/etc/init.d/mosquitto b/net/mosquitto/files/etc/init.d/mosquitto
index 0fa7a3a8f..e7c1110c1 100755
--- a/net/mosquitto/files/etc/init.d/mosquitto
+++ b/net/mosquitto/files/etc/init.d/mosquitto
@@ -91,6 +91,7 @@ convert_mosq_general() {
append_if "$1" sys_interval
append_if "$1" upgrade_outgoing_qos
append_if "$1" user
+ append_optional_bool "$1" per_listener_settings
}
convert_persistence() {
@@ -144,6 +145,10 @@ add_listener() {
append_optional_bool "$1" use_identity_as_username
append_optional_bool "$1" use_subject_as_username
append_if "$1" psk_hint
+ append_if "$1" auth_plugin
+
+ # Careful, this relies on internal behaviour of the cfg_load functions!
+ set | grep "CONFIG_$1_auth_opt_" | sed "s/^.*_\(auth_opt_.*\)='\(.*\)'/\1 \2/" >> $TCONF
}
add_topic() {