aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-12 12:32:14 -0800
committerRosen Penev <rosenp@gmail.com>2018-11-12 12:34:54 -0800
commitb8312b58cf8951626f7c535a8942a06a559c747e (patch)
treef3974f3a02233cfa94a62aa70975610df53f77e7
parentcae5d145dbacac2edaa5c4f5e3230e5a3e80ed78 (diff)
clamsmtp: Really fix compilation
It seems Linux headers are broken/incompatible with musl for some reason. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--mail/clamsmtp/Makefile2
-rw-r--r--mail/clamsmtp/patches/010-fix-build.patch29
2 files changed, 19 insertions, 12 deletions
diff --git a/mail/clamsmtp/Makefile b/mail/clamsmtp/Makefile
index aa3e31e4f..3eb6d88be 100644
--- a/mail/clamsmtp/Makefile
+++ b/mail/clamsmtp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=clamsmtp
PKG_VERSION:=1.10
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=http://thewalter.net/stef/software/clamsmtp/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/mail/clamsmtp/patches/010-fix-build.patch b/mail/clamsmtp/patches/010-fix-build.patch
index a3d88dcee..a285a7739 100644
--- a/mail/clamsmtp/patches/010-fix-build.patch
+++ b/mail/clamsmtp/patches/010-fix-build.patch
@@ -1,12 +1,19 @@
-diff --git a/common/sock_any.h b/common/sock_any.h
-index 77c3841..1e30974 100644
---- a/common/sock_any.h
-+++ b/common/sock_any.h
-@@ -39,7 +39,6 @@
- #ifndef __SOCK_ANY_H__
- #define __SOCK_ANY_H__
-
--#include <sys/socket.h>
- #include <sys/un.h>
- #include <netinet/in.h>
+--- a/configure.in
++++ b/configure.in
+@@ -78,16 +78,6 @@ AC_CHECK_HEADERS([limits.h err.h paths.h],,)
+ AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h string.h netdb.h], ,
+ [echo "ERROR: Required C header missing"; exit 1])
+-# Check for linux type transparent proxy support
+-AC_CHECK_HEADERS([linux/netfilter_ipv4.h],
+- AC_DEFINE(LINUX_TRANSPARENT_PROXY, 1, [Whether the system supports a linux type transparent proxy]),
+- ,
+- [[
+- #ifdef HAVE_LIMITS_H
+- #include <limits.h>
+- #endif
+- ]] )
+-
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+ AC_TYPE_SIZE_T