aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-11 16:21:51 -0700
committerRosen Penev <rosenp@gmail.com>2019-09-03 12:44:51 -0700
commitb80b614f8f659e352723a49cc4459521049198ab (patch)
tree84a27f85313aad0d63eb62691f5a67dbe605c7ec
parentc111125d3cfde0cd1def4c9ecf919dea7a1036f0 (diff)
softethervpn: Add missing OpenSSL header
Fixes compilation without OpenSSL deprecated APIs as well as -Werror=implicit-function-declaration. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--net/softethervpn/Makefile2
-rw-r--r--net/softethervpn/patches/140-openssl-header.patch10
2 files changed, 11 insertions, 1 deletions
diff --git a/net/softethervpn/Makefile b/net/softethervpn/Makefile
index a7a4df39d..b5f9c4378 100644
--- a/net/softethervpn/Makefile
+++ b/net/softethervpn/Makefile
@@ -12,7 +12,7 @@ PKG_NAME:=softethervpn
PKG_VERSION:=4.29-9680
PKG_VERREL:=rtm
PKG_VERDATE:=2019.02.28
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=softether-src-v$(PKG_VERSION)-$(PKG_VERREL).tar.gz
PKG_SOURCE_URL:=http://www.softether-download.com/files/softether/v$(PKG_VERSION)-$(PKG_VERREL)-$(PKG_VERDATE)-tree/Source_Code/
diff --git a/net/softethervpn/patches/140-openssl-header.patch b/net/softethervpn/patches/140-openssl-header.patch
new file mode 100644
index 000000000..b9b98e5de
--- /dev/null
+++ b/net/softethervpn/patches/140-openssl-header.patch
@@ -0,0 +1,10 @@
+--- a/src/Mayaqua/Secure.c
++++ b/src/Mayaqua/Secure.c
+@@ -127,6 +127,7 @@
+ #include <openssl/pkcs7.h>
+ #include <openssl/pkcs12.h>
+ #include <openssl/rc4.h>
++#include <openssl/rsa.h>
+ #include <openssl/md5.h>
+ #include <openssl/sha.h>
+ #include <Mayaqua/Mayaqua.h>